How to create directory /sysrcd/ in the partition root?

All other questions
Post Reply
Posts: 1
Joined: 19 Mar 2015, 02:14

How to create directory /sysrcd/ in the partition root?

Post by rayberau » 19 Mar 2015, 02:32

I want to install rescue 32 and altker 32 onto a 500Mb partition formatted fat 16 on the hard drive of my MacBook 6.1 (2009 32-bit has no MacHDD or Rescue Disk). The only OS on the hard drive is Linux Puppy Tahr 6.0 on /mnt/sda9 which boots only with the Tahrpup DVD in the DVD-reader at the moment, but I intend to install System Rescue 32 on /mnt/sda10. Both these partitions are part of extended partition /mnt/sda3, but I have installed Grub4Dos on /mnt/sda1/ which is NTSC.

I have access to the terminal of the graphical environment with the System Rescue (32-bit or 64-bit) DVD in the DVD-reader and I want to install the System Rescue CD to /mnt/sda10 (extended/logical 500Mb fat16 partition) but don't know exactly how to follow the instruction "create directory /sysrcd/ in the root of the partition." This instruction is given at ... n_harddisk where they expect that the reader will know what to type in the terminal in order to create a directory /sysrcd/ in the root of the partition, in my case in partition 10.

I tried to just type (after % in the xfce terminal) "create directory /sysrcd/ > /mnt/sda10" but there was no such command. I tried "-h" and "help" to get a list of commands but there was no such command. I could start again using Puppy Tahr OS and try the different terminal there that uses "#" instead of "%" (or "$" as I have seen in Linus Mint and Ubuntu).

I tried "mkdir /mnt/mydir/sysrcd/" but got "Cannot create directory ' /mkdir /mnt/mydir/sysrcd/' - anyway, that doesn't specify where I want to create the directory, nor does it place it in the root of partition 10.

I tried these: "mkdir /sda10/sysrcd/" and "mkdir /mydir/sda10/sysrcd/" and mkdir sda10/sysrcd/", and for all of these I got "Cannot create directory ... No such file or directory.

Does anyone know the correct way to make a Linux command (after % or # or $) to create a directory in sda10? Can anyone help? I'll try Googling for UNIX and Linux commands but so far have not worked out what to put after "mkdir".

Actually, I may have succeeded. I just typed "mkdir /sda10/sysrcd/", and the enter key, and it didn't say "no such file ..." so maybe it is created now in root of sda10 partition. I'll copy all the sysrcd files to sda10 now and see how I go.

Thank you and regards from Ray Bergmann, Brisbane, Australia

Posts: 1131
Joined: 07 Apr 2010, 16:19

Re: How to create directory /sysrcd/ in the partition root?

Post by gernot » 20 Mar 2015, 08:00

You need a filesystem like e.g. FAT32 on /mnt/sda9.
gparted helps.

then mount the filesystem to a mountpoint:

a mountpoint is a local directory. Create one if need:
mkdir /mnt/mountpoint

then mount the partition:
mount /mnt/sda9 /mnt/mountpoint

create the syrcd on /dev/sda9 rootdirectory:
mkdir /mnt/mountpoint/sysrcd

after all is done unmount /dev/sda9
umount /dev/sda9


Post Reply