eth0 not found error [solved]

All other questions
Post Reply
reader
Posts: 15
Joined: 13 Jul 2010, 12:22

eth0 not found error [solved]

Post by reader » 24 Apr 2014, 07:31

The computer is a Dell optiplex 760.
Here is a strange effect. I see it in 4.1.0 and also 4.2.0 so it is not something new to sysresc.
This problem is not seen when using knoppix 7.3
The command ifconfig eth0 returns the message:
eth0: error fetching interface information: Device not found

Using net-setup eth0 , there is no complaint about the device name and the ip is correctly set as seen from an outside ping as well as the simple command ifconfig (without argument).
The device is then shown to be enp0s25
Typing ifconfig enp0s25 gives the expected results.

These tests have been repeated on another identical PC with the same results.
= = =

lem
Posts: 11
Joined: 10 Apr 2013, 08:20
Location: France

Re: eth0 not found error

Post by lem » 02 May 2014, 06:56

Hi,

same problem with a HP Compaq dc7900.
It seems to be not hardware specific, am I right ?

miket
Posts: 2
Joined: 02 May 2014, 19:11

Re: eth0 not found error

Post by miket » 02 May 2014, 19:45

You're up against one of the most controversal features of recent versions of udev, the so-called persistent network interface names. It's an amazingly wrongheaded way to avoid a race condition possible in a distribution like SystemRescueCD that does dynamic loading of device-driver modules during system initialization. Only machines having multiple Ethernet interfaces are liable to this condition, yet udev imposes its awkward solution on everybody.[1] Most machines have only one Ethernet interface, some laptops have a single WiFi interface, and some machines have one of each. None of those cases could run afoul of this race condition, but everybody is supposed to suffer through names like enp0s25. There has been a lot of noisy discussion on all this in the Gentoo forums.

The good news is that you can get eth0 back. You have to edit the kernel command line in the boot menu (hit the TAB key once you've moved to a selection) and add this argument to the kernel command line:

Code: Select all

net.ifnames=0
Remember that this argument must have a space between it and other arguments on the command line. Hit the ENTER key when you've made the edit and SystemRescueCD will boot with udev instructed not to change the interface names that the kernel assigns.

----

[1] There is a somewhat better way to avoid the race condition which lets you assign meaningful names of your choice to network interfaces by editing the udev rules, but the technique is not really appropriate for a rescue CD, which you are supposed to be able to plop in anywhere.

gernot
Posts: 1131
Joined: 07 Apr 2010, 16:19

Re: eth0 not found error

Post by gernot » 03 May 2014, 11:16

Thank you for this info. I think this solve the OP problem.

Gernot

reader
Posts: 15
Joined: 13 Jul 2010, 12:22

Re: eth0 not found error

Post by reader » 05 May 2014, 12:59

Many thanks miket for your explanation as well as the solution.

I have tested your fix and it cures the problem that I was having.

Post Reply