A bug: Locales and nicode support are completely broken

Topics about the system utilities that are not related to Hard-disk and storage
Sap
Posts: 8
Joined: 05 Feb 2015, 08:50

A bug: Locales and nicode support are completely broken

Postby Sap » 10 Feb 2015, 09:23

Some programs print errors about locales.
Example (the system's been booted with 'setkmap=ru' option):

Code: Select all

> locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
...
LC_ALL=

So no non-ASCII characters is available (and the worse is that non-ASCII file names are not accessible!) .
In /etc/locale.gen all lines are commented out.
locale-gen falls with error:

Code: Select all

> echo "en_US.UTF-8" >> /etc/locale.gen
> echo "ru_RU.UTF-8" >> /etc/locale.gen
> locale-gen
* Generating 1 locales (this might take a while) with 1 jobs
 *  (1/1) Generating ru_RU.UTF-8 ...character map file `en_US.UTF-8' not found: No such file or directory
cannot open locale definition file `ru_RU': No such file or directory
 [ !! ]
 * Generation complete

There is no any locale definition files ('locale-gen -A' falls with all errors), so it can only be fixed by sysrcd maintainers in sysrcd image - I am looking how to post a bug report. Is this forum enough?
Keyboard layouts don't work as well. And there is no unicode support in console.

Return to “System software”

Who is online

Users browsing this forum: No registered users and 2 guests