PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Topics about the system utilities that are not related to Hard-disk and storage
Scruffy
Posts: 4
Joined: 27 Jan 2013, 19:22

PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby Scruffy » 27 Jan 2013, 19:34

I have used systemrescuecd on an occasional basis for several years now and I'm hoping you can make a change to the default live cd that will disable suspend/sleep modes COMPLETELY as a default setting. The reason I am asking for this is if I start a lengthy process (disk cloning for example) and I have to leave the computer unattended for a while, when I get back, the PC is asleep and NOTHING I've tried yet will wake it up. The display is off, the ps2 keyboard and mouse are powered off, the NIC is asleep, and even the USB ports are powered off. That means the only choice I have is to force the computer to reboot without any way to find out what the status of the process that was running when it went to sleep. This is such a simple thing to fix, and I can't for the life of me understand why anyone would want it to go to sleep under those conditions anyway. Thanks for an otherwise fantastic product, and thanks for considering my request.

gernot
Posts: 1123
Joined: 07 Apr 2010, 16:19

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby gernot » 27 Jan 2013, 20:12

Yes this would be good. I lost some hours to this problem.

In my case no linux setting helped because the buggy BIOS was it.
At least after removing all timeouts in the bios setup my backup worked.

Gernot

Scruffy
Posts: 4
Joined: 27 Jan 2013, 19:22

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby Scruffy » 27 Jan 2013, 20:34

Yes, improperly executed suspend and sleep modes in BIOS, HW, and OS have been causing problems for users, admins, and manufacturers for decades now. Things are better today than they ever have been, and yet even now, it's still a common problem. Even using the latest HW and SW, the problem still persists to this day. I realize that some people will want this to be available to them, but when you consider the PRIMARY purpose and usage for the live cd is likely to be data recovery, system repair, and the like, I think it makes more sense to avoid as many potential problems as possible. This will give the largest number of people the best chance of successfully using the live cd without risking another potential source for data loss or damage to their system.

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby admin » 03 Feb 2013, 10:56

I will disable the following kernel options in the next beta version (3.4.0-beta010)
# CONFIG_SUSPEND is not set
# CONFIG_HIBERNATION is not set
# CONFIG_USB_SUSPEND is not set
# CONFIG_HIBERNATE_CALLBACKS is not set
Please let me know there is still a problem, and if you know which options should be turned off.

gernot
Posts: 1123
Joined: 07 Apr 2010, 16:19

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby gernot » 04 Feb 2013, 16:20

In my case (scenic xl) the new settings work.
2.6.0 hang in suspend where 3.4.0-beta010 run without problems.

Thanks
Gernot

cschanzle
Posts: 11
Joined: 28 Sep 2009, 21:34

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby cschanzle » 18 Mar 2013, 16:04

While I understand the problem, the solution seems heavy-handed.

I frequently need to secure-erase laptop SSD's (with TRIM support) using 'hdparm --security-erase'. To do this, the drive must be in an "unfrozen" state. Performing a suspend/resume is the easiest way to thaw the drive.

Is there no other way to disable suspend by default but still leave it available to others if they choose?

Thanks!

Scruffy
Posts: 4
Joined: 27 Jan 2013, 19:22

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby Scruffy » 26 Mar 2013, 17:48

Sorry I haven't replied sooner, but I would like to report that I have had a chance to use sysresccd 3.4.35 rather extensively, and I'm thrilled to report that I've not had any issues with suspend/sleep at all! Thank you SO much for the changes! I wish I could tell you which settings are needed for the best compatability, but unfortunately, I don't really have any idea. I understand that there are uses/needs that I've not found yet for the power save features, but as things are now, I can happily say that I can rely on your product to get the job done.

Thanks so much,
Scruffy

Edit:
I don't see a way to mark this as solved, so if the admins/moderators would do that for me, I would be thankful.

Dukers
Posts: 36
Joined: 16 Jun 2008, 16:55

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby Dukers » 12 Apr 2013, 20:35

I'm with cschanzle.

I was trying to secure erase a SSD and because the BIOS puts it in "frozen state" without kernel suspend support I just can't do it anymore.

"echo -n "mem" >/sys/power/state", press power button and the SSD is not "frozen" anymore. Need other rescue Linux now...

ConiKost
Posts: 8
Joined: 14 Jan 2011, 18:00

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby ConiKost » 19 Apr 2013, 12:35

I would like also to get this enabled back. Or at least an alternative kernel.
I can't unfreeze my ssd, as this is only possible with going to s3 (suspend to ram).

cschanzle
Posts: 11
Joined: 28 Sep 2009, 21:34

Re: PLEASE ENABLE POWER SAVE/SLEEP BY OPTION!

Postby cschanzle » 29 Apr 2013, 22:23

After researching this more, is Scruffy's (OP) and Gernot's problems caused by Linux talking to a buggy BIOS via APM (ancient, doesn't look like sysrcd has apmd) or ACPI? If that is true, simply disabling ACPI (kernel boot arg 'acpi=off') would be sufficient and allow suspend for the majority of us without broken hardware. I'd even be fine with 'acpi=off' becoming a default boot argument. But please don't unset CONFIG_ACPI. :-)

Thank you for your consideration!

jomcty
Posts: 17
Joined: 23 Jan 2013, 15:06

Re: PLEASE ENABLE POWER SAVE/SLEEP BY OPTION!

Postby jomcty » 29 Apr 2013, 22:30

cschanzle wrote:... simply disabling ACPI (kernel boot arg 'acpi=off') would be sufficient and allow suspend for the majority of us without broken hardware. I'd even be fine with 'acpi=off' becoming a default boot argument. But please don't unset CONFIG_ACPI. :-)!

Ditto.

gernot
Posts: 1123
Joined: 07 Apr 2010, 16:19

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby gernot » 01 May 2013, 18:42

I think activating ACPI and suspend only in the alternate kernel would be the best for the most users.
New hardware with SSD should work with the alternate kernel while older bad BIOS work "better" with the standard kernel.

Gernot

Dukers
Posts: 36
Joined: 16 Jun 2008, 16:55

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby Dukers » 02 May 2013, 11:43

Did you try acpi=off on a pre-3.4.0 sysrcd?

gernot
Posts: 1123
Joined: 07 Apr 2010, 16:19

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby gernot » 03 May 2013, 14:01

Dukers wrote:Did you try acpi=off on a pre-3.4.0 sysrcd?

Yes, it don't work on the bad PC.

Gernot

cschanzle
Posts: 11
Joined: 28 Sep 2009, 21:34

Re: PLEASE DISABLE POWER SAVE/SLEEP BY DEFAULT!

Postby cschanzle » 06 May 2013, 22:28

gernot wrote:
Dukers wrote:Did you try acpi=off on a pre-3.4.0 sysrcd?

Yes, it don't work on the bad PC.


Could you be more specific? E.g., Brand / model / motherboard?
It's hard to comprehend how 'acpi=off' couldn't work.
Anyone else with similar experience?


Return to “System software”

Who is online

Users browsing this forum: No registered users and 1 guest