testdisk recovery taking too long; disconnecting disks?

Topics about disk partitioning (fdisk, parted, gparted, partimage), Volumes Management (lvm, evms, dmraid), Storage, file systems, ...
larjona
Posts: 1
Joined: 22 Jul 2015, 19:37

testdisk recovery taking too long; disconnecting disks?

Postby larjona » 22 Jul 2015, 19:49

Hi everybody
Thanks for your work in SystemRescueCD, it's a life saver.

I had I/O errors in a laptop hard disk and I launched SysRescCD's testdisk in order to copy /home to an external USB disk before replacing the dying harddisk.

It's taking too long! 5 complete days working, and 250 GB of data copied (from ext4 partition in harddisk to NTFS partition in USB disk) and I suppose there are at least 50 GB more... No I/O errors in dmesg; it seems the damaged part is somewhere else in the disk.

I wonder if it's normal that speed; USB is 2.0 and hard disk is SATA, laptop from 2010.

I wonder if the system is disconnecting disks (the harddisk and/or the USB one) when becoming idle for some energy saving policy... How can I be sure that is not happening?

Thanks again

gernot
Posts: 1126
Joined: 07 Apr 2010, 16:19

Re: testdisk recovery taking too long; disconnecting disks?

Postby gernot » 23 Jul 2015, 05:05

Broken HD can be damn slow. They can spin down and restart after every block.
Testdisc recover partitiontables. Use you photorec?

Try ddrescue to copy the bad partition to a file on a good Harddisk. Run photorec there.
With a logfile you can stop and continue.
If your HD has "slow" block ranges without errors use the '--min-read-rate=bytes' option

Make sure to use a filesystem that can hold huge files as target.

Gernot


Return to “Hard-disk partitioning and storage”

Who is online

Users browsing this forum: No registered users and 2 guests