Network Manager freezes with acpi=off

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
Post Reply
Posts: 1
Joined: 20 Aug 2016, 23:18

Network Manager freezes with acpi=off

Post by Nullbodu » 20 Aug 2016, 23:24


Live usb just hangs during boot if I set acpi=off boot parameter, without it live usb works fine. It just stays forever saying

Code: Select all

Starting NetworkManager...
nonm boot option does nothing. I hope you can help me, thanks.

P.S. I really need acpi=off option because otherwise my ssd won't be detected.

Posts: 86
Joined: 22 Jun 2012, 02:24

Re: Network Manager freezes with acpi=off

Post by vanepp » 22 Aug 2016, 01:01

I suspect (but don't know for sure) that you are hosed. The various nos (nodhcp, nonm, etc.) haven't worked since 3.x something. I think (but again don't know for sure) that the addition of udev broke the lot of them. I remember reading the last time I poked at this (a year or two ago) on the gentoo site that eudev was being forked in part to fix this, but at this time all I can find is a protracted flame war about eudev (which appears to be the default in gentoo at this time) nothing obvious about whether it does fix the various options. If you are adventurous you may want to try emerging eudev from gentoo and see if that indeed makes (or can be made to make) the various no kernel options work again. I'm intending to do this sometime, but haven't gotten to it yet, so I wouldn't hold my breath :-). If you make it work, please post back so we can pressure to get it included in the rescueCD, I'd like the options to work again. When last I poked at this in init the options disappeared in to udev and don't appear to come out the other side and are ignored by udev.

Post Reply