does nothing on Ubuntu 16.04

Post there if you have problem when downloading the iso, or burning it.
Post Reply
Posts: 1
Joined: 28 Dec 2016, 03:00 does nothing on Ubuntu 16.04

Post by jcobban » 28 Dec 2016, 03:07

I have tried to install the System Rescue CD ISO to a USB using the procedure described on the System Rescue CD web site but nothing happens.
  • I downloaded the ISO to my Downloads directory
  • mkdir -p /tmp/cdrom
  • sudo mount -o loop,exec Downloads/systemrescuecd-x86-4.9.0.iso /tmp/cdrom
  • plug in the USB
  • umount the USB by clicking on the up-arrow on the icon for the USB
  • sudo bash /tmp/cdrom/ I also tried cd /tmp/cdrom and sudo bash
  • The script displays /dev/sdb as the only USB device
  • I select OK and click enter
  • the script terminates immediately without writing anything to the USB
I cannot see the log file if one is written by the script because everything in /var/tmp is hidden inside gibberish directories which I do not have the authority to look inside because Ubuntu 16.04 uses SystemD

I also tried the alternative method:

dd if=Downloads/systemrescuecd-x86-4.9.0.iso of=/dev/sdb
dd: failed to open '/dev/sdb': Permission denied
[email protected]:~$ sudo dd if=Downloads/systemrescuecd-x86-4.9.0.iso of=/dev/sdb
dd: failed to open '/dev/sdb': No medium found

So how do I install System Rescue CD to a USB on Ubuntu 16.04?

Posts: 1
Joined: 28 Dec 2016, 15:32

Re: does nothing on Ubuntu 16.04

Post by Schmonz » 28 Dec 2016, 15:38

Hello jcobban,

I do not have a USB stick at hand to try it out, but I think the up-arrow icon also deregisters the device from your computer. That means no program can access the raw USB interface any more.

Please check if entering sudo umount /dev/sdb1 on a command line instead of using the up-arrow button does the trick.


P.S.: systemd does not restrict access to your system internals, neither am I sure if browsing /var/tmp will help you with your problem. If you need to see the syslog for your current boot, just execute sudo journalctl -b and scroll to the bottom to view the most recent items (or press Shift+G to access the last line directly).

Posts: 1
Joined: 04 Jan 2017, 21:07

Re: does nothing on Ubuntu 16.04

Post by ragallup » 04 Jan 2017, 21:22

It appears to me that the instructions on ... _USB-stick are not correct for systemrescuecd-x86-4.9.0.iso. Enter

Code: Select all

./ -h
to see the usage message. By following option B, Sub-commands for manual installation, I was able to successfully create a bootable USB stick.

Here is the usage message:

Code: Select all

./ SystemRescueCd installation script for USB-sticks
Syntax: ./ <command> ...

Please, read the manual for help about how to use this script.

You can either run all sub-commands in the appropriate order, or you
can just use the semi-graphical menu which requires less effort:

A) Semi-graphical installation (easy to use):
   Just run "./ dialog" and select the USB device

B) Sub-commands for manual installation (execute in that order):
   1) listdev               Show the list of removable media
   2) writembr <devname>    Recreate the MBR + partition table on the stick
   3) format <partname>     Format the USB-stick device (overwrites its data)
   4) copyfiles <partname>  Copy all the files from the cdrom to the USB-stick
   5) syslinux <partname>   Make the device bootable

C) Extra sub-commands:
   -h|--help	            Display these instructions

Distributed under the GNU Public License version 2 -

Post Reply