Cannot find /sysrcd.dat on device ...

Post there if you have problem when downloading the iso, or burning it.
Post Reply
Posts: 2
Joined: 18 Jul 2016, 12:38

Cannot find /sysrcd.dat on device ...

Post by iliv » 18 Jul 2016, 13:00

I followed this manual ... filesystem and the blog post ... -your.html it links to and successfully installed and booted rescue32.

However, when the OS tried to mount disk devices it failed by printing "Cannot find /sysrcd.dat on device ..." multiple times and eventually dropped me into a mini shell.

There's probably something wrong about this installation method because I used to have systemrescuecd installed on USB sticks from version 1.3.5 up to 3.8.1 without any problems using the same hardware I attempt to use 4.8.0 on today.

Just for giggles I tried to install 3.8.1 on a USB stick as described in section E) of the manual, and the blog post, and it worked exactly like 4.8.0. Booted just fine but when OS tries to mount devices it prints "Cannot find /sysrcd.dat on device ..." error message multiple times and eventually drops me into the mini shell. I then tried 1.3.5. It was different but ultimately worse. It hung during the boot process with a kernel panic message and kernel traceback on the screen.

These are the images (1.3.5 and 3.8.1) that I know used to work on this hardware. I just don't recall how exactly I installed systemrescuecd but I'm absolutely positive these images worked. Hence the statement that there must be something about the installation method described in the manual and the blog post.

Anyway, I tried to search this forum and the duck but I couldn't find anything to help me solve this problem.

Some troubleshooting info:

* cat /proc/partitions does show all my block devices.
* /sysrcd.dat is in the root.
* rescue32 image boots just fine and the problem happens during system initialization (init)

My partitions layout on USB stick is 2 FAT32 partitions + 1 EXT4 partitions where the SystemRescueCD is installed.

I would appreciate any help. Completely baffled as to why I'm having this problem. Installing and using SystemRescueCD has always been a very smooth and straightforward experience for me.

Posts: 2
Joined: 18 Jul 2016, 12:38

Re: Cannot find /sysrcd.dat on device ...

Post by iliv » 18 Jul 2016, 13:08

I'd like to clarify something. The system I use to install SystemRescueCD on a USB stick doesn't have isohybrid or syslinux installed on it.

Using the default recommended method ( ... from_Linux) didn't work either:

Code: Select all

Installation on /dev/sde at 2016-07-18_10:36
The device [/dev/sde] seems to be big enough: 30176 MB.
--> /var/tmp/usb_inst.tmp/install-mbr /dev/sde --force
--> /var/tmp/usb_inst.tmp/parted -s /dev/sde mklabel msdos error: /var/tmp/usb_inst.tmp/parted -s /dev/sde mklabel msdos --> failed
I guess 30GB partition is just too large for a msdos type partition. Anyway, I actually want to have one or more partitions that would allow me to use this USB stick as a normal stick plus have SystemRescueCD on the third partition to help me boot and fix broken systems whenever the need be.

Post Reply