2.8.1b3 Cannot find /sysrcd.dat on devices (YUMI, SOLVED)

Post there if you have problem when downloading the iso, or burning it.
Post Reply
Posts: 3
Joined: 29 Jun 2012, 14:30

2.8.1b3 Cannot find /sysrcd.dat on devices (YUMI, SOLVED)

Post by jaalto » 29 Jun 2012, 14:52

I'm unable to boot either 2.8.0 or 2.8.1beta003 from USB flash drive YUMI[1]. The mini shell appears and the error is:

Code: Select all

Cannot find /sysrcd.dat on devices
This is identical problem that was posted earlier in http://www.sysresccd.org/forums/viewtop ... =14&t=3154

The /sys/block lists sda, sdb, sr0. I'm suspecting that the rescuecd isn't noticing this flash drive's unique properties: It's sanDisk U3 4G Cruzer (only flash drives I have). The drive which contains 2 partitions. The sr0 is the "U3 Partition" data partition that is read-only with sanDisk Windows software. The writeable partition is /dev/sdb1 under which YUMI's /multiboot directory, and rescuecd, resides.

Let me know if anything else is needed. Let me also know how can I save output from the console to the USB stick to be able to possibly post the information back here.

[1] http://www.pendrivelinux.com/yumi-multi ... b-creator/
Last edited by jaalto on 29 Jun 2012, 20:32, edited 1 time in total.

Posts: 1131
Joined: 07 Apr 2010, 16:19

Re: 2.8.1b3 Cannot find /sysrcd.dat on devices (USB Cruzer U

Post by gernot » 29 Jun 2012, 16:11

sysrcd.dat must be in the root directory of the stick. If your stick writer use a subdirectory add subdir=... to the boot command line.
The sysrcd initscript list all tested devices. Is /dev/sdb1 in the list?
Find you sysrcd.dat and sysrcd.md5 manual with the minishell?

You can mount any device and pipe into a file on it. Dont forget umount.

p.s. sysrcd's initrd cant read frpm USB3 hostadaper.

Posts: 3
Joined: 29 Jun 2012, 14:30

Re: 2.8.1b3 Cannot find /sysrcd.dat on devices (USB Cruzer U

Post by jaalto » 29 Jun 2012, 19:34

> sysrcd.dat must be in the root directory

find / -name "sysrc*" does not return anything.

The YUMI is syslinux based and boots through grub boot loader. I'm not sure what to make of subdir=... boot parameter. The /dev/sdb1 where YUMI's /multiboot directory would be, contains only ISO image files. The sdb is not mounted when sysrecue boots.

I removed U3 from the USB[1] to make in single partition and reinstalled 2.8.1b3.The symptoms stayed the same. I'm booting from USB 2.0 port.

How can I find sysrcd.dat from currently booted system (mini shell)?[2]


P.S. The http://www.sysresccd.org/Sysresccd-manu ... the_CD-ROM does not list subdir= param.
[1] Remove U3 Software From Your USB Flash Drive http://www.geekyjock.com/pages/blog/200 ... flash.html
[2] I can find sysrcd.dat if I mount -o loop <location of ISO in YUMI sdb1> /mnt/iso. Can I use it somehow to boot current system?
Last edited by jaalto on 30 Jun 2012, 07:02, edited 2 times in total.

Posts: 3
Joined: 29 Jun 2012, 14:30

Re: 2.8.1b3 Cannot find /sysrcd.dat on devices (YUMI solved)

Post by jaalto » 29 Jun 2012, 20:31

Okay, solved. Here are the instructions for YUMI multiboot which makes it possible to install multiple Linux or other ISOs to a single USB flash drive:

1. Install YUMI (Windows) http://www.pendrivelinux.com/yumi-multi ... b-creator/
2. Download systemrescue ISO
3. Start YUMI and make multiboot disk on USB flash drive: in Step 2 scroll to bottom of choices and pick Try an unlisted ISO and press Browse button to locate ISO file from disk.
4. Boot USB and select systemrescue ISO. Remember to arrange BIOS to boot from USB first. I even needed to disable HDD boot in order to get USB boot noticed (Samsung ultrabook 900X3C-A01 2012 model; disable also Fast Boot from Samsung easy settings).

Select keymap from presented list and let the boot fail, that's normal. The idea is that you manually extract the needed files from ISO to the root of USB flash drive. On the mini shell, run:

5. cat /proc/partitions (to find out your USB, the sd* device; mine was sdb1)
6. mkdir /mnt/usb /mnt/iso
7. mount /dev/sdb1 /mnt/usb
7. cd /mnt/usb/multiboot/ISOS (locate the right ISO from list of files)
9. mount -o loop systemrescue*.iso /mnt/iso
10. cp /mnt/iso/sysrcd.* /mnt/usb (copy files to the ROOT of USB)

Done. Rebooot and from YUMI, select systemrecue ISO. It can now can find the crucial files.

Post Reply