problem install to usb - device is too small

Post there if you have problem when downloading the iso, or burning it.
Post Reply
bicchi
Posts: 2
Joined: 17 Sep 2010, 23:12

problem install to usb - device is too small

Post by bicchi » 17 Sep 2010, 23:18

I have a problem installing version 1.6 to a USB. I tried it with 2 USBs and both are over 4 GB. Perhaps there is a bug in the code that checks drive space.

$ cat /var/tmp/usb_inst.log

Installation on /dev/sdc at 2010-09-17_19:03
/dev/sdc: No medium found
usb_inst.sh: error: The device [/dev/sdc] is only 0 MB. It is too small to copy all the files, an USB-stick of at least 300MB is recommended

gernot
Posts: 1131
Joined: 07 Apr 2010, 16:19

Re: problem install to usb - device is too small

Post by gernot » 18 Sep 2010, 09:02

bicchi wrote:/dev/sdc: No medium found
are you sure with /dev/sdc ?

try "sysresccd-usbstick listdev" to list all devices or use "dmesg" after inserting the target to get more info.

Gernot

bicchi
Posts: 2
Joined: 17 Sep 2010, 23:12

Re: problem install to usb - device is too small

Post by bicchi » 20 Sep 2010, 14:25

Found my problem and here is the solution in case someone else encounters it.

I am using Ubuntu which automounts remobable devices and I was right clicking the device and ejecting it before trying to run the usb install script. I was under the impression that eject also did the unmount. Using umount from the command line fixes the problem and now it is showing the correct size and installing.

ninjasinloaf
Posts: 1
Joined: 26 Jan 2011, 02:48

Re: problem install to usb - device is too small

Post by ninjasinloaf » 26 Jan 2011, 02:49

Perfect! Thanks!

Cholsonic
Posts: 1
Joined: 16 Mar 2011, 11:31

Re: problem install to usb - device is too small

Post by Cholsonic » 16 Mar 2011, 11:38

I had the same problem as bicchi with the USB drive reading as only 0MB. I tried the umount /dev/sdb (in my case) however this returned message saying that it was not mounted.

i looked at my devices found there was a /dev/sdb1 so umounted this instead and it went through.

Drive now restored to full capacity and install proceeded as it should

Cheers

bugmenotplease
Posts: 42
Joined: 17 May 2010, 18:50

Re: problem install to usb - device is too small

Post by bugmenotplease » 21 May 2011, 06:19

bicchi wrote:Found my problem and here is the solution in case someone else encounters it.

I am using Ubuntu which automounts remobable devices and I was right clicking the device and ejecting it before trying to run the usb install script. I was under the impression that eject also did the unmount. Using umount from the command line fixes the problem and now it is showing the correct size and installing.
Thank you! It worked out! Could someone please add this information to USB-stick install? Thanks!

P.S. I'm running Ubuntu 10.10 with Gnome2

Post Reply