Issues with usb_inst.sh on 64-bit system

Post there if you have problem when downloading the iso, or burning it.
Post Reply
iainfrerichs
Posts: 1
Joined: 28 Jun 2010, 15:01

Issues with usb_inst.sh on 64-bit system

Post by iainfrerichs » 28 Jun 2010, 15:13

I managed to get the System Rescue CD installed on a USB stick but only after some messing about.

My System is Fedora Core 12 x86_64

1. The usb_inst/* programs rely on /lib/ld-linux.so.2 and /lib/libc.so.6 (32-bit) and these are not present or available on the 64-bit platform. I copied ld-2.5.so and libc-2.5.so from a 32-bit CentOS 5 system to /lib/ and the programs then worked. But it might be better to statically link to libc and ld in usb_inst and provide these here also.

2. Some USB sticks report 0 in /sys/block/sdX/removable - mine did. I had to change the test in is_dev_usb_stick (grep for "USB" in $vendor worked for me...) before I could complete installation.

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: Issues with usb_inst.sh on 64-bit system

Post by admin » 28 Jun 2010, 22:24

Thanks for having reported that problem. The binaries should work on 100% 64bit system with sysresccd-1.5.7-beta9
The second problem (removable attribute) is more complicated to fix. I guess it's a bug in the kernel. There is no easy workaround for that...

Post Reply