If "How to" on USB from Windows does not work for

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
quibble
Posts: 1
Joined: 10 Oct 2007, 15:55

If "How to" on USB from Windows does not work for

Postby quibble » 10 Oct 2007, 16:11

Instead of using the syslinux command found in the wiki manual in step-03:
"syslinux E:"

try
"syslinux -ma E:"

remembering, of course, to substitute your own drive letter for "E:"

this worked on my Sony 4gb micro vault tiny

rbxouxedu
Posts: 5
Joined: 30 Nov 2007, 17:01

Thanks for the hint!

Postby rbxouxedu » 18 Dec 2007, 15:24

It'd be nice if the "syslinux -ma E:" was included in the online Handbook in English/French/Spanish to Chapter 12.

It should probably go in step 3.

admin
Site Admin
Posts: 2707
Joined: 17 Jul 2003, 09:44

Postby admin » 19 Dec 2007, 07:18

Thanks, I updated the manual.

rbxouxedu
Posts: 5
Joined: 30 Nov 2007, 17:01

Postby rbxouxedu » 19 Dec 2007, 19:34

It should be noted that "syslinux -ma E:" only works with the win32 version of syslinux and not the Linux version.

If you're in Linux just use your preferred partition software (like cfdisk) to mark the partition bootable.

-m means write mbr
-a means make drive partition active (aka bootable).

fbab
Posts: 1
Joined: 12 Jan 2008, 17:17

Postby fbab » 12 Jan 2008, 17:20

Under Windows, with a Freecom USB drive, I had to add the -f option :
syslinux.exe -maf E:

darko
Posts: 2
Joined: 11 Sep 2008, 06:03

Postby darko » 11 Sep 2008, 06:15

In Linux you should install MBR with something like
"cat /usr/lib/syslinux/mbr.bin | sudo tee /dev/sdX>/dev/null" or
"install-mbr /dev/sdX" in which case you need package mbr.
It really should be mentioned in manual, it would save me and probably other people lot of time. None of the above solutions works in Linux.

By the way SystemRescueCd is excellent work. I love it, USB stick with it is in my pocket all the time!

Littlejohn
Posts: 1
Joined: 29 Sep 2008, 22:44

Postby Littlejohn » 29 Sep 2008, 22:49

Hi all,

I tried all the different variations found in this thread but I still get 'syslinux' is not recognized as an internal or external command...

I'm doing it from Vista. ...the ultimate goal here is to partition my vista box and install Ubuntu so I can slowly wean my family(and myself) off Windows...

How would I correct this?

Thanks!

darko
Posts: 2
Joined: 11 Sep 2008, 06:03

Postby darko » 30 Sep 2008, 06:34

Ubuntu live (install) CD can re-partition (resize) you drive during the installation.

Citizenview
Posts: 1
Joined: 20 Mar 2009, 23:04

Failure to install Sysrescue on USB stick

Postby Citizenview » 20 Mar 2009, 23:11

I am sorry to state that I could not make an USB stick bootable from SystemRescue CD that I burned. I tried this from within the Windows, i.e. a Vista setup 64 bit. Copying/renaming was a breeze. cannot find the file syslinux.exe. Help please...


Return to “Boot problems”

Who is online

Users browsing this forum: No registered users and 2 guests