SystemRescueCd / PartImage works, now it does not

Topics about disk partitioning (fdisk, parted, gparted, partimage), Volumes Management (lvm, evms, dmraid), Storage, file systems, ...
Post Reply
Posts: 1
Joined: 25 Jul 2009, 15:40

SystemRescueCd / PartImage works, now it does not

Post by andre72 » 25 Jul 2009, 16:13

Testing SystemRescueCD on two systems that I was reconfiguring:

1. AMD64 machine, backed up the Win2K NTFS 20GB system partition to an ext3 backup partition. Restored it successfully later. System Rescue Disk established network connections correctly and allowed internet access.

2. Tried the same on a Dell Dimension WinXP machine. First issue, unable to connect to the network. Backed up the WInXP 60GB partition to an ext3 backup partition. Could not restore it later, recceived an "invalid compression level for file sysc.gz.000" message. Repeated the whole operation again, creating a new backup image, with the same result.

System Rescue CD packs an impressive array of utilities, but I am afraid there is an issue of dependability.

Why do I get an "invalid compression level" restroring a file created by the very same disk?

Posts: 35
Joined: 29 Jul 2009, 19:20

Post by Ruler » 30 Jul 2009, 20:39

I'm new here, so take this for what it's worth. I have used the SRCD for several years now on literally hundreds of machines. It's become an indispensable part of my troubleshooting toolkit.

I've had trouble with some of the newer Dell boxes. It appears that they like using new (proprietary) drive controllers. It takes the Linux community a bit to become aware of them and then create drivers that allow them to work 100%. I'd be willing to bet in a version or two, it'll work perfectly on that machine.

A workaround is to carry a couple adapters that turn an IDE/SATA drive into a USB drive. They're about $20 or so and completely bypasses the drive controller in a given PC. It's also great for data recovery and really impresses people when you whip it out. ;) :D You can also try booting the alternate kernel that's on the CD. Sometimes it works, sometimes not.

Post Reply