Cannot boot iBook G4 with sysresccd-ppc-0.2.0

Questions about how to use the PPC version of SysRescCd.
Post Reply
Posts: 1
Joined: 19 May 2007, 18:15

Cannot boot iBook G4 with sysresccd-ppc-0.2.0

Post by sgalzin » 19 May 2007, 21:12


I've checked this forum for a hint on this problem but haven't found any; however, on the net, I've found (few) other people who seem to have the same problem... (example of another post signaling the problem : ... ost2141292)

When I boot my iBook G4 with the burned sysresccd-ppc-0.2.0.iso I get the boot prompt (which enables different advanced booting modes). If I just press Enter the boot process starts, a few messages appear (all sem to be linux loading information), and after a few seconds my screen just stays blank (black). I hear the CD-Rom do some more work for about a minute (as if the booting process was still actually going on just without any visual output) and then the computer just stays still, nothing happens.

Note : when I try different boot options an error message saying that the image cannot be found shows up.

Since this was my first try booting my Mac from a live CD I tried xubuntu and it worked perfectly. The LiveCD I want though is SRCD :-(

Any help, hints or links will be much apreciated, Thanks !


Posts: 1
Joined: 28 Jun 2008, 16:39

iBook Boot Issues

Post by kirbaceous1 » 28 Jun 2008, 16:42

Hi, this won't apply to may people, but for any Mac users: I just discovered that during the boot phase the rescue disc blanks the screen. Using the brightness controls I have been able to see the display again! :D

Post Reply