need 32 bit version of binutils

All other development questions
hamed1988
Posts: 1
Joined: 19 Sep 2013, 07:31

need 32 bit version of binutils

Postby hamed1988 » 19 Sep 2013, 07:34

Hi,
I need 32 bit version of binutils to compile some other scripts.

when I try to install it using emerge, it does not find the package.

Code: Select all

emerge -epv sys-devel/binutils

 * IMPORTANT: config file '/etc/portage/package.keywords' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "sys-devel/binutils".


I downloaded the source of binutils and compiled it, it compiles a 64 bit version of the "AS" script in binutils, while I need a 32 bit version of that.

Code: Select all

uname -a
Linux sysresccd 3.2.33-std311-amd64 #2 SMP Wed Oct 31 07:31:30 UTC 2012 x86_64 Common KVM processor GenuineIntel GNU/Linux


Could someone help me or provide me with the working binary of a 32 bit version of "AS" script?

Thanks

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: need 32 bit version of binutils

Postby gernot » 19 Sep 2013, 14:01

Tried you to boot sysresccd explicit with the 32 bit kernel?

Gernot


Return to “Other”

Who is online

Users browsing this forum: No registered users and 3 guests