Small bug USB stick installation with

All other development questions
Post Reply
Posts: 1
Joined: 16 Jan 2013, 13:14

Small bug USB stick installation with

Post by Hko » 16 Jan 2013, 13:33


First of all: thanks for making SystemRescueCd available to the public! I use SystemRescueCd now and then for a few years now on USB-stick, PXE netboot and CD.

I downloaded SystemRescueCd-x86-3.2.0 today to boot from an USB-stick. To prepare the stick I followed Recommended USB installation method from Linux and I think I ran into 2 small bugs in the walk-through text or the
script (depending how you look at it).

First the script ended without any message, so I thought it was done. The stick however had no MBR nor any other contents. I tried to wiped the partition table of the stick and tried again. Nothing.

Looking at the log file I noticed that the directory /mnt/usbstick was expected. So I created it. Then it became clear that the script does expect a partition to be created on the stick.

Both of these requirements were not mentioned on the doc's page "Recommended USB installation method from Linux", nor did the script mention it (expect for the log) or issue any error message about it.

After creating directory /mnt/usbstick and a partition on the stick, things worked like a charm! Thought I should report this, since the fact that script silently expects /mnt/usbstick to exist and no error (nor success) message appeared, this did confuse me for s while.

Regards, Heiko

Post Reply