Page 1 of 1

image checksum error (after editing iso with magicISO)

Posted: 28 Jul 2004, 15:02
by telenut
I would like to ad some software to the same disk (there is plenty of space left) But I get an error on boot: image chacksum error.
How can I rebuild it so I don't have that error? (And using windows)

Posted: 29 Jul 2004, 08:15
by admin
You have to rebuild the ISO with mkisofs. There is a windows version of this program.

Posted: 13 Apr 2008, 22:34
by fallout33
Could someone please post the necessary parameters for the creation of the ISO?

I tried to create a new bootable CD (including my custom autorun file) with ImgBurn by using the files, folders and the bootloader of the original ISO.
no emulation
load segment 07C0
sectors to load 4

But I also got the checksum error.

Therefore I want to find out how to create the ISO with mkisofs.




Update:
After doing some searching I stumbled across an example for the usage at ping.windowsdream.com

The following call worked for me:

Code: Select all

mkisofs -b isolinux/isolinux.bin -boot-info-table -boot-load-size 4 -no-emul-boot -o ../rescuecd_new.iso .

Posted: 14 Apr 2008, 06:58
by jotape99
Did you follow the sysresccd manual ?
http://www.sysresccd.org/Sysresccd-manu ... _ISO_image

Posted: 14 Apr 2008, 07:43
by fallout33
jotape99 wrote:Did you follow the sysresccd manual ?
Yes I did and it worked.

But like the user telenut I am using Windows. Therefore I don't want to reboot every time and go through the procedure of creating the ISO, reboot again into Windows, burn the image and then reboot again for testing the CD all over again.

Re: image checksum error (after editing iso with magicISO)

Posted: 12 Feb 2016, 03:10
by gatorback
Is there a simple explanation of why magicISO is not able to add files to the .iso image?

Re: image checksum error (after editing iso with magicISO)

Posted: 13 Feb 2016, 08:40
by gernot
I don't use MagicISO, but i added many times the firefox srm with growisofs. Just watch to use the right extensions -R

Gernot