Page 1 of 1

usb_inst.sh fails if mtools are missing (silently)

Posted: 26 Jun 2010, 22:59
by topfpflanze
hi,

a quick search on the forum did not reveal any topics concerning this, so i just post it here (sorry if its the wrong location)

i downloaded "systemrescuecd-x86-1.5.6.iso" and followed the instructions on "http://www.sysresccd.org/Sysresccd-manu ... _USB-stick"

the installer (usb_inst.sh) finished with: "the installation successfully completed"
but the usb stick has not been bootable.

after evaluating the logs i found:

Code: Select all

sh: mcopy: command not found                                                                                                                                                                                                                 
/tmp/usb_inst.tmp/syslinux: failed to create ldlinux.sys
after installing mtools everything worked like a charm.

it would be nice if:
a) the wiki would mention this dependency
b) the installer would not report success

anyway, thanks for all your hard work, i do love systemrescuecd!

Re: usb_inst.sh fails if mtools are missing (silently)

Posted: 27 Jun 2010, 13:15
by admin
Thanks, it has been fixed in SystmeRescueCd-1.5.7-beta8. Can you confirm it works for you ?

Re: usb_inst.sh fails if mtools are missing (silently)

Posted: 27 Jun 2010, 16:41
by topfpflanze
admin wrote:Thanks, it has been fixed in SystmeRescueCd-1.5.7-beta8. Can you confirm it works for you ?
yes, everything works as expected.
(it seems that mtools aren't needed anymore)

Re: usb_inst.sh fails if mtools are missing (silently)

Posted: 27 Jun 2010, 17:50
by admin
Thanks for having tested. syslinux still requires mtools. This dependency has just been added to usb_inst so that the installation script can use it.