Update efibootmgr to 0.11.0 [solved]

Post there if an important software is missing and has to be added
KC2ZGU
Posts: 2
Joined: 10 Jan 2015, 03:35

Update efibootmgr to 0.11.0 [solved]

Postby KC2ZGU » 30 Jan 2015, 19:00

The efibootmgr package on the current system rescue CD release (and even 4.5.0 beta), 0.6.0, is not compatible with the EFI-based firmware on some current machines. I have noticed incorrect behavior on Fujitsu T731, Lenovo x140e, and Kontron KTQM67. Run "efibootmgr -v" and look for "wierd[sic] path" messages, possibly scrolling by in an endless loop. Version 0.11.0 seems to fix these issues. This tool is useful for installing or repairing recent systems that are using UEFI boot mode.

Compler compatibility note: efibootmgr 0.11.0 requires efivar 0.15, which does not compile out of the box on gcc <4.7. I was able to make it compile under 4.5 by removing the -std=gnu11 and -Wmabe-unititialized flags from the default makefile, but have not verified functionality. Builds using 4.7 or 4.8 do work.

nickalreadytaken
Posts: 101
Joined: 21 Oct 2010, 12:29

Re: Update efibootmgr to 0.11.0

Postby nickalreadytaken » 27 Jun 2015, 06:41

efibootmgr-0.11.0 is included in the latest version.


Return to “Software request”

Who is online

Users browsing this forum: No registered users and 4 guests