(Solved) Can't log on to Windows

All other questions
PenguinDreams
Posts: 1
Joined: 16 Mar 2009, 06:56

(Solved) Can't log on to Windows

Postby PenguinDreams » 16 Mar 2009, 07:22

I got a virus on Windows XP and after quarantining and deleting a bunch of files I can't log on anymore. Instead of just opening like it used to I now get a logon screen asking for a password. It does this for the administrator account in safe mode too. Neither account has ever had a password so I used Ophcrack to see if a new password had been written somehow. It came up blank.

Then I loaded the rescueCD to add a password but it tells me there is no NT MD4 hash and no LANMAN hash and I can't write a new password because it can't find the hive.

So I tried copying the SAM file from the recovery directory over to the system32/config file and it let me reset the password but I still get the message "unable to log you on because of an account restriction".

I've got Ubuntu installed on another drive so I was at least able to make backups of my files but I don't know what else to do to make Windows work. Help??
-------

Turns out I was dealing with a corrupted registry. I was able to use the rescueCD to copy the files from the repair file over to the config file, restart in safe mode and then restore all my settings from a previous a previous restore point (viruses and all - stupid windows). This is an great tool for all kinds of issues. Thanks!!

tyrannski
Posts: 1
Joined: 20 Apr 2012, 22:10

Re: (Solved) Can't log on to Windows

Postby tyrannski » 20 Apr 2012, 22:46

Hello,

i know this thread is old, but i have the same problem.

I don't know what happend but i can't log into my windows XP anymore. From one day to another i am confronted with a login screen and asked to entere a password. I never set a password and was never confronted with a login screen before.

I created a System Rescue CD and tried to clear any possible password. In the user list i have 2 admin accounts "admin" and "Administrator". "admin" has the status *blank* and "Administrator" has the status dis/lock.

I edited the status of "admin" anyways and cleared the password. Then i edited "Administrator" and cleard the password too. In user list the status remained dis/lock. So i edited "Administrator" and unlocked it. After that the status in user list was *blank* too.

When i now edit both accounts it says "No NT MD4 hash found" and "No LANMAN hash found".

After reboot i am confronted with the login screen again and asked for a password for the account "admin". Entering a blank password gives an error message saying the password is too short.

Then i started windows in safe mode and the login screen showed both admin accounts ("admin" and "Administrator") asking for passwords. Entering blank passwords gave the same error message.

What else can i do? Where can i find these repair files and how do i use them?

I am desperate, what possibilities do i have? Any help is appreciated!

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: (Solved) Can't log on to Windows

Postby gernot » 21 Apr 2012, 07:30

This is the MS way to solve the problem:
http://support.microsoft.com/kb/307545

In short words you replace the registry files with a older version stored "in" a restore point.
After successful boot run "system restore". Then rollback to a restore point to get a consistent system.

If you understand what happens its possible to shorten the procedure using sysrcd.

Gernot


Return to “Other”

Who is online

Users browsing this forum: No registered users and 1 guest