Page 1 of 1

Disable kernel module loading on custom initramfs.igz

Posted: 02 Nov 2015, 20:55
by sibok
Hi,

my machines, which run GNU/Funtoo Linux on 2 Raid 0 arrays needs an initramfs with dmraid support to boot into the system. Last 7 years i've been using a custom initramfs which has been working fine while the machine only had a single raid0 array but 10 days ago i bought a pair of ssd hard drives and after plugging them i noticed the custom initramfs was only able to activate a single set of the 2 pairs of Raid 0 arrays. So i downloaded last version of SystemRescueCD and grabbed its initramfs.igz which worked like a charm but as i do not need most of services/libraries it provides i'm customizing this initramfs. By now i've disabled everything i don't need except "dodmraid" functions and as i also removed /lib/modules directory it complains about not being able to load /lib/modules/3.19.3-1~exp1/modules.dep

What i'm trying to accomplish is to avoid loading kernel modules as i don't need them but i'm not able to find what is calling them. The error message appears after this loading message "Activating dmraid (fake hardware raid)..." so i'm looking into "/sbin/dmraid-activate" script and udev config files.

Hope there's a developer around here who can help. Thx!!

Re: Disable kernel module loading on custom initramfs.igz

Posted: 07 Nov 2015, 12:01
by sibok
No one knows?

Re: Disable kernel module loading on custom initramfs.igz

Posted: 07 Nov 2015, 15:46
by gernot
I don't understand the problem.
in the sysresccd initrd is a shellscript named init
This script contain the functions. e.g. sysresccd_setup_volumes

To test you can boot with the minishell option and edit init. Then call ". init" again

Gernot

Re: Disable kernel module loading on custom initramfs.igz

Posted: 09 Nov 2015, 00:13
by sibok
I don't want to test. i'm successfully booting into GNU/Funtoo Linux through an initramfs based on the one included in SystemRescueCD. What i want is to be able to remove /lib/modules directory located in the initramfs without getting the mentioned /lib/modules/*/modules.dep error as i do not need any modules included in the initramfs, the problem is udev and maybe other scripts are trying to load some modules hich i do not know. Obviuously i do not need them but the srcripts seems to eb calling modprobe on this modules.

Re: Disable kernel module loading on custom initramfs.igz

Posted: 09 Nov 2015, 08:09
by gernot
In the sysresccd initrd is only one main script which load the modules.
This script is named init. You have to edit this script to change that.

Gernot

Re: Disable kernel module loading on custom initramfs.igz

Posted: 09 Nov 2015, 19:44
by sibok
gernot wrote:In the sysresccd initrd is only one main script which load the modules.
This script is named init. You have to edit this script to change that.

Gernot
Just curious, did you take a look at the initramfs.igz? It looks like you didn't. Also did you read my first post? Especially when i say By now i've disabled everything i don't need except "dodmraid" functions and as i also removed /lib/modules directory it complains about not being able to load /lib/modules/3.19.3-1~exp1/modules.dep

Please, would you be so kind to stop your pointless answers? I really appreciate your time but if you read again your answers you will notice they do not resolve the issue and are neither a good contribution. In fact they provide no help at all.

Kind regards.

Re: Disable kernel module loading on custom initramfs.igz

Posted: 09 Nov 2015, 22:03
by gernot
Yes, I read your post.
sibok wrote:So i downloaded last version of SystemRescueCD and grabbed its initramfs.igz which worked like a charm but as i do not need ...
Yes I dived into the initrd you grabbed.
Yes, i found the how it load modules.

Yes i'm quite now.

Gernot

Re: Disable kernel module loading on custom initramfs.igz

Posted: 10 Nov 2015, 19:46
by sibok
gernot wrote: Yes, i found the how it load modules.
Gernot
Yes, you found something you're not able to even understand.

LOL