Page 1 of 1

problem running 64bit application

Posted: 03 Dec 2013, 16:38
by crowd1
I am using sysrescuecd to automaticly configure some ibm servers in my lab.
There is an IBM utility which called asu (advanced scripting utility) to set some of the machine configuration. this util comes in both 64 and 32 bit.
I need my sysrescue to run with 64bit kernel (had some issues when tried to run with 32bit kernel) so i tried to run this "asu" util after booting into 64 bit kernel.
When i tried the asu/32bit app i got a message (from the app) saying "this app is for x86 systems, you are using unsupported system (x64)"
when i tried to run asu/64bit app i got a message that the file is not executable (probably because there are no 64 lib's in the sysrescue distribution).
I also tried to run the asu/32bit from sysrescue which loaded with 32bit kernel and it worked like a charm (but then again i can't use this kernel for my hole system needs).

I have two questions:

1. is it possibale to make the application think it is running on 32bit kernel (even though it is running on 64bit) ?

2. How can i install specific 64 libs which are required by this app ? I mean where can i find this libs to install (i did ldd asu/64bit in a full redhat installation and figured that there are 6 libs this app is using)


Re: problem running 64bit application

Posted: 08 Dec 2013, 05:51
by crowd1
Anyone ?
Any idea ?