services with `-' in their names ignored during startup

Post questions about how to make a customized SystemRescueCd, and if you have problems to install new packages. Please read the handbook first.
MSK61
Posts: 1
Joined: 26 Feb 2012, 21:41

services with `-' in their names ignored during startup

Postby MSK61 » 26 Feb 2012, 23:42

I downloaded systemRescueCD 2.4.1 and followed the online customization procedure to create a custom CD. I added a few packages, one of which was avahi. Now when I added initscript:avahi-daemon:start to the boot options to start the avahi-daemon service at startup, the service didn't start. Examining the file /etc/init.d/sysresccd, I found that the pattern initscript=[a-zA-Z0-9]{1,32}:[a-z]{1,32} is used to capture any service-action pairs specified in the boot options; this pattern clearly doesn't detect hyphens(-) in service names, like the avahi-daemon service. When I modified the pattern to include the hyphen in the service name, the avahi-daemon service was correctly started during startup. This's probably a problem that needs to be permanently fixed in the /etc/init.d/sysresccd service.

Return to “Customization and installing new packages”

Who is online

Users browsing this forum: No registered users and 1 guest