Low speed for CIFS for LAN 1Gb conections on SRCd ver 1.5.8

Topics about the networking software (ssh, nfs, samba, ...). No questions about network drivers there.
krystianm
Posts: 2
Joined: 27 Jul 2010, 17:14

Low speed for CIFS for LAN 1Gb conections on SRCd ver 1.5.8

Postby krystianm » 27 Jul 2010, 17:46

Hello,

I copy data from mounted lockal SATA disk to another mounted CIFS share,
and watch if use SystemRescueCd ver 1.5.8 and copy date, transfer is ~ 8-18 MB/s,
but if use SystemRescueCd ver 1.1.6 transfer is ~28-60MB/s

From this differences ? Can sombody clear up me this?

Thank you, Krystian

P.S.

the same hardware configuration but another SystemRescueCd version another effective ?

lockal PC:
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
eth0:
Settings for eth0:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 3
Transceiver: external
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Link detected: yes

copy from
mount -t vfat -o utf8,rw,umask=000,uid=0,gid=0 /dev/sdb1 /1/d
mount -t vfat -o utf8,rw,umask=000,uid=0,gid=0 /dev/sdc1 /1/e
mount -t vfat -o utf8,rw,umask=000,uid=0,gid=0 /dev/sda5 /1/f
to
mount -t cifs //192.168.100.249/c /2

Server PC:
01:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
ASRock

Settings for eth1:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
Link detected: yes

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: Low speed for CIFS for LAN 1Gb conections on SRCd ver 1.

Postby gernot » 27 Jul 2010, 18:15

it would be interesting to check if its a network- , harddisk- or a CIFS-problem.

You can use "hdaparm -t /dev/sd..." to test the HD-speed

to check the raw networkspeed:

Code: Select all

"dd if=/dev/zero|nc -l -p 1234 " on one Box and
"nc other_ip 1234  | pv >/dev/null " on the other

stop with "ctrl c". make sure there is a space between 1234 and the pipesymbol

Gernot

krystianm
Posts: 2
Joined: 27 Jul 2010, 17:14

Re: Low speed for CIFS for LAN 1Gb conections on SRCd ver 1.

Postby krystianm » 28 Jul 2010, 00:11

Hello,

thank you gernot for answer, in particular for scripts to RAW LAN test

I run all test and

"Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)" on server is broken, after change hardware all work properly in SystemRescueCd 1.5.8 too ;)

but why in 1.1.6 make no odds ?

again thank you

P.S.

on slackware 13.1 x64 not have pv found on
http://pipeviewer.googlecode.com/files/pv-1.1.4.tar.bz2

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: Low speed for CIFS for LAN 1Gb conections on SRCd ver 1.

Postby gernot » 28 Jul 2010, 04:27

krystianm wrote:but why in 1.1.6 make no odds ?

I think its the kernel. Tried you the alternate kernel?

Maybe slackware use an ozher pipe meurement tool.

Gernot


Return to “Networking (except PXE booting)”

Who is online

Users browsing this forum: No registered users and 2 guests