Network configuration problem

Topics about the networking software (ssh, nfs, samba, ...). No questions about network drivers there.
strowi
Posts: 21
Joined: 04 Dec 2008, 10:25

Network configuration problem

Postby strowi » 25 Jun 2010, 10:31

hi,

i would like to have network configured automatically to use either eth0 or wlan0.
I remastered sysrcd with a custom wpa configuration and added wpa_supplicant to the boot runlevel.
Then i added dodhcp to the kernel options.

So far it boots and starts udhcp on eth0, but it continues indefinetly if no cable connected, is there any way i could set a timeout, or check for a link (like dhcpcd does)?

When the cable is connected it seems to work perfect.

PS: Could you please update dhcpcd to 5.x? That would solve a lot of problems (including the above).

greetings,
strowi

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: Network configuration problem

Postby admin » 25 Jun 2010, 10:46

Be aware the Network-Manager is now started by default. If you want to configure the network using standard tools you will have to turn it off:
rc-update del Network-Manager

or boot with the "nonm" option to automatically disable this service at run time. Or maybe you could write a configuration file for the network manager instead. This utility if quite good with wireless connections.

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: Network configuration problem

Postby gernot » 25 Jun 2010, 16:53

strowi wrote:So far it boots and starts udhcp on eth0, but it continues indefinetly if no cable connected

Continue it realy indefinetly? I have a box with two NICs. dodhcp get the IP for the connected NIC and loops 25 times for the unused one.
It would be nice if the loop is "shorted" a bit if one NIC is configurated.

gernot

strowi
Posts: 21
Joined: 04 Dec 2008, 10:25

Re: Network configuration problem

Postby strowi » 30 Jun 2010, 15:50

hi,

well i didn't wait 25 cycles, i aborted after ~1:30min..

I see now how the networkmanager is used... although i thought it only connects to a network after a user is logged in? Does also work on console?
How/where is the config stored so i can make it connect either via eth0 or wireless on boot automatically (I have only used a combination of dhcpcd-5 and wpa_suppliant, which worked fine)?

greetings,
strowi


Return to “Networking (except PXE booting)”

Who is online

Users browsing this forum: No registered users and 1 guest