v1.5.1 generates INACCESIBLE_BOOT_DEVICE [Solved]

Topics about disk partitioning (fdisk, parted, gparted, partimage), Volumes Management (lvm, evms, dmraid), Storage, file systems, ...
Post Reply
LarryDC
Posts: 1
Joined: 10 May 2010, 18:30
Location: Riverside RI EE.UU.
Contact:

v1.5.1 generates INACCESIBLE_BOOT_DEVICE [Solved]

Post by LarryDC » 10 May 2010, 18:40

Since subject version uses GParted 0.5.2, I thought I was safe.

The whole 39.08 GB drive was NFTFS running Win 2000. I reduced the NTFS to sda1 @ 9.76 GB and added 1 GB SWAP (sda2), an 11.85 GB reiserfs (sda3) and a 14.65 GB ext4 (sda4). I did it all in one operation.

Perhaps I should have only have resized the NTFS, applied then shutdown?

1) fdisk -l -u
Disk /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders, total 78165360 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x63116311

Device Boot Start End Blocks Id System
/dev/sda1 * 63 20482874 10241406 7 HPFS/NTFS
/dev/sda2 20482875 22587389 1052257+ 82 Linux swap / Solaris
/dev/sda3 22587390 47439944 12426277+ 83 Linux
/dev/sda4 47439945 78156224 15358140 83 Linux

2) parted /path-to-your-device unit s print
Model: ATA WDC WD400BB-53CA (scsi)
Disk /dev/sda: 78165360s
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 63s 20482874s 20482812s primary ntfs boot
2 20482875s 22587389s 2104515s primary linux-swap(v1)
3 22587390s 47439944s 24852555s primary reiserfs
4 47439945s 78156224s 30716280s primary ext4

3) I fixed the problem via "Proposition of a tutorial for the NTFS size bug - NOT YET VALIDATED" at http://gparted-forum.surf4.info/viewtopic.php?id=13937

with gedakc's suggestion of using hexedit. After I determined that greegthe geek counted in hex when he wrote "Look for the row 20, " (to us unwashed that is the '3rd row down, but numbered 00...20')

As pointed out the first reboot into windows after the "dd if=/some/where/myCurrentPbr.pbr of=/dev/sda bs=512 count=1 seek=63" does require letting the system do a chdsk. Automatically in my case.

Thanks,
Larry De Coste

Post Reply