Device busy

Topics about disk partitioning (fdisk, parted, gparted, partimage), Volumes Management (lvm, evms, dmraid), Storage, file systems, ...
Post Reply
eQuest
Posts: 1
Joined: 19 Dec 2009, 10:45

Device busy

Post by eQuest » 19 Dec 2009, 11:00

Hi Community,
i have a problem with one of my partitions. Here the whole story:
On my laptop there was installed windows xp. After some while i wanted to install windows 7 and so i did, without problems. But then i checked my explorer and one of my partitions had vanished. I tried to assign a new drive pattern, but it wasn't possible. Something was strange about my partition, once i tried to rewrite the mbr, but without success. Then, after playing sometime, i was fed up and decided to try to save the most important files through rescue cd and create a new partition somehow. So I started the rescuecd and looked up the partitions:

Code: Select all

[email protected] /root % fsarchiver probe detailed
[=====DEVICE=====] [==FILESYS==] [=====LABEL=====] [====SIZE====] [MAJ] [MIN] [==============LONGNAME==============] [==================UUID==================] 
[/dev/sda1       ] [ntfs       ] [<unknown>      ] [    49.19 GB] [  8] [  1] [/dev/sda1                           ] [1684734F8473307B                        ] 
[/dev/sda2       ] [ntfs       ] [School & Arbeit] [    78.14 GB] [  8] [  2] [/dev/sda2                           ] [94C8523FC8522032                        ] 
[/dev/sda5       ] [ntfs       ] [Files          ] [   170.75 GB] [  8] [  5] [/dev/sda5                           ] [0E5C642E5C6412AF                        ] 
[/dev/sdb1       ] [ntfs       ] [EXTERNE_FAM    ] [   931.51 GB] [  8] [ 17] [/dev/sdb1                           ] [B042F0CB42F09776        
ok the partition I'm talking about is sda5, the one with 170GB. So i tried to mount with ntfs-3g:

Code: Select all

[email protected] /root % ntfs-3g -o ro /dev/sda5 /mnt/windows
ntfs_mst_post_read_fixup: magic: 0x454c4946  size: 4096  usa_ofs: 48  usa_count: 2: Invalid argument
Actual VCN (0x100380002000f) of index buffer is different from expected VCN (0x0).
ntfs_mst_post_read_fixup: magic: 0x454c4946  size: 4096  usa_ofs: 48  usa_count: 2: Invalid argument
Actual VCN (0x100380002000f) of index buffer is different from expected VCN (0x0).
So that's the end of my story and it would be great if you can help me so =/ How can I repair the partition or at least get access to the files so that i can save them? thank you guys

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: Device busy

Post by admin » 19 Dec 2009, 20:09

You should check your filesystems using chkdsk from Windows (or ntfsfix from SystemRescueCd).

It's possible to copy the files, just follow that tutorial:
http://www.sysresccd.org/Sysresccd-manu ... s_computer

Post Reply