Cannot find correct XP partition to remount for XP passowrd

Topics about disk partitioning (fdisk, parted, gparted, partimage), Volumes Management (lvm, evms, dmraid), Storage, file systems, ...
Post Reply
SweatyBanana
Posts: 3
Joined: 08 Aug 2009, 01:23

Cannot find correct XP partition to remount for XP passowrd

Post by SweatyBanana » 08 Aug 2009, 01:39

Ok... In short, I am having problems mounting my actual XP Media Center Edition as NTFS while using the SystemRescueCD to change my administrator password so I can use windows system recovery (BSOD on boot for windows)...

Code: Select all

HPFS-NTFS   0   1   1   22839 254 63   366924537 [HP_PAVILION]
This is the partition with all of my C drive information (windows) but I can't mount the c drive with the command:

cat /proc/partitions

Code: Select all

a few up here....
8            16        195360984   sdb
a few down here...
Now I already checked with the testdisk what partition my windows copy is on and it said it was 'sdb'... Whenever I try to mount my hard drive, it says:

Code: Select all

ntfs-3g /dev/sdb /mnt/WINDOWS -oforce
NTFS signature is missing.
Failed to mount '/dev/sdb': Invalid argument
The device 'dev/sdb' doesn't seem to have a valid NTFS.

etc...etc... (you guys all know what it says "maybe the wrong device is used......"
I don't understand why my NTFS windows copy won't mount... Any help guys?


Hope I provided enough info for you.

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Post by admin » 08 Aug 2009, 07:28

Try to identify the windows partition with this:
fsarchiver probe simple

You will get something like that:

Code: Select all

[email protected] /root % fsarchiver probe simple
[=====DEVICE=====] [==FILESYS==] [=====LABEL=====] [====SIZE====] [MAJ] [MIN]
[/dev/sdb1       ] [ext3       ] [boot           ] [   976.55 MB] [  8] [ 17]
[/dev/sdb2       ] [reiserfs   ] [gentoo         ] [    16.00 GB] [  8] [ 18]
[/dev/sdb3       ] [ntfs       ] [winxp32        ] [    16.00 GB] [  8] [ 19]
[/dev/sdb4       ] [lvm2pv     ] [<unknown>      ] [   898.56 GB] [  8] [ 20]

SweatyBanana
Posts: 3
Joined: 08 Aug 2009, 01:23

Post by SweatyBanana » 08 Aug 2009, 19:45

Code: Select all

[/dev/sdb1            ] [ntfs           ] [HP_PAVILION     ] [    174.96 GB] [  8] [ 17]

and...

Code: Select all

ntfs-3g /dev/sdb1 /mnt/windows

returns...

Code: Select all

ntfs-3g-mount: mount failed: Device or resource busy

Code: Select all

df -m
/dev/sdb1                179163     94069   130095   28%   /mnt/windows
Something seems wrong there... I know for a fact that my C drive is much more than 28% full. Any ideas?


and...

Code: Select all

cd /mnt/windows/WINDOWS/System32/config
and...
cd /mnt/windows/windows/System32/config

returns...

cd: no such file or directory: /mnt/windows/WINDOWS/System32/config
cd: no such file or directory: /mnt/windows/windows/System32/config

Now my windows installation goes as follows...
C:\WINDOWS\...

Code: Select all

dr-xr-xr-x      0       0        0      19-JUL-2009 03:21 WINDOWS

->

dr-xr-xr-x      0       0        0      19-JUL-2009 03:21 system32

->

dr-xr-xr-x      0       0        0      29-JUL-2009 03:22 config

->

-r--r--r--        0       0       262144    19-JUL-2009 03:22 SAM

-r--r--r--        0       0           8192    19-JUL-2009 03:22 SAM.LOG

SweatyBanana
Posts: 3
Joined: 08 Aug 2009, 01:23

Post by SweatyBanana » 08 Aug 2009, 20:12

ah....



I am so stupid.... system32 != System32


But in my defense, I tried to mount sdb1 so many times last night and it wouldn't work until this morning... :P



New problems...

After I go through this, my XP recovery still says:
Type the administrator password:
The password is not valid. Please retype the password.

Code: Select all

chntpw -l SAM
chntpw -u Administrator SAM
2
newpassword
Y

and...

chntpw -l SAM
chntpw -u HP_Administrator SAM
2
newpassword
Y

Post Reply