Page 1 of 1

Problems with PartImage and EXT4FS

Posted: 25 May 2009, 17:24
by scott.programming
Using RescueCD version 1.2.0, I cannot backup any EXT4 partitions (Ubuntu 9.04, official) on several machines. I keep getting the error "Can't read bitmap block 0 from image". I've tried backing up to both a local USB drive, as well as a network drive, same results. Also, partimage sees the file system as EXT3, not EXT4. Gparted sees the file system as EXT4, and finds no errors or problems with the partition.

Partimage works fine for EXT3FS, NTFS, FAT, and FAT32 partitions, with all of the same hardware, to both a local USB drive, as well as a network drive.

Anyone else have this problem? Anyone have any solutions?

Posted: 25 May 2009, 17:59
by kfgz
http://www.partimage.org/Main_Page wrote:Warning: Partimage does not support ext4 and btrfs filesystems. If you need an ext4 / btrfs support or if you need modern features (checksumming, multi-thread compression, encryption, flexibility in the size) you should try FSArchiver.
Besides FSArchiver you can use partclone which is on Parted Magic livecd (test version) http://beefdrapes.partedmagic.com/

Posted: 27 May 2009, 02:54
by scott.programming
kfgz,
Took your advice, and tried out fsarchiver...worked very well, without a hitch. I went so far as to take another old ext3 installation, and restore/convert it to ext4. No problems at all.

I've been using partimage for more than a year, but never attempted it before now, on an ext4 partition...thanks for the info.

BTW, I wonder if ext4 will ever be incorporated into partimage? That would be really nice, but, I can deal with "plan B (fsarchiver)", as long as it works.

Again, thanks for the advice and the info. People like you, are what makes Linux, second to none!

Scott



Microshaft, is a joke for support, unless you have a big checkbook. From MS, you'll probably get another 950 MB service pack, that will just create more problems, then you can buy the "upgrade".