v1.1.7 respects hard disk hpa causing buffer I/O error

Topics about disk partitioning (fdisk, parted, gparted, partimage), Volumes Management (lvm, evms, dmraid), Storage, file systems, ...
Post Reply
Frank Wang
Posts: 5
Joined: 04 May 2006, 08:19

v1.1.7 respects hard disk hpa causing buffer I/O error

Post by Frank Wang » 02 May 2009, 14:40

The Sysresccd used to work fine here until recently upgraded to v1.1.7. There're many computers here by Lenovo have hpa enabled in the factory for fast Windows recovery. For these boxes with Linux installed, say Ubuntu 8.04 Hardy, the hpa of the hard disk is ignored by the kernels and the full capacity is used. If such computers is booted with the v1.1.7, hpa will be respected now and the OS will see a smaller disk. This will cause trouble because the partition table, lvm and filesystem were allocated according to the original bigger disk. A lots of buffer I/O error will be raised in dmesg and utility like fsck is probably not safe to run now.
A little search says a libata.ignore_hpa=1 parameter will restore the old behavior but it's not work for the 2.6.27 kernel in the v1.1.7. Some says an "option libata.ignore_hpa=1" should be appended to the modprobe.conf. I'll build a custom cd to see if it works. Still, it better to have a boot menu option to choose if hpa should be enabled.

Regards,
Frank Wang

Frank Wang
Posts: 5
Joined: 04 May 2006, 08:19

Post by Frank Wang » 03 May 2009, 05:08

The customed cd with a /etc/modprobe.d/libata-options still doesn't work. The file is created by: echo options libata ignore_hpa=1 > /etc/modprobe.d/libata-options
Ref: https://bugs.launchpad.net/ubuntu/+sour ... bug/270151

Post Reply