Restoring OpenSuSE Problem

Questions about problems with your hardware. For example, if you the kernel hangs during boot because of an hardware failure or if you have a problem with a driver not working or missing.
Post Reply
Posts: 2
Joined: 16 Feb 2014, 23:03

Restoring OpenSuSE Problem

Post by nexz » 16 Feb 2014, 23:42

I am familiar with SysRescCD and had been using this tool for some years, mostly for Windows cloning. And I like thank developers and supporters for this great tool.

Recently, I am trying to clone OpenSuSE 12.3 to identical hardware except video card. Normally, I will copy dos partition table (MBR + partition table) and clone each partition. I can restore it to exact same box (orig image was created) without any problem. But when I clone to identical hardware, I got the following problems.

1. I have 3 partitions of type ext3: /, swap, /home. I can restore to / and don't need to restore swap. When I restore /home, OpenSuSE went to emergency mode. It asked me to look at output of 'journalctl -b' and here is the output:

....lots of lines here, I don't think they are errors....
....the following 4 lines are highlighted in red....
Timed out waiting for device dev-disk-by-id\x2did-ata\x2dWDC_WD800BB\x2d00JHC0_WD\x2dWMAM9DEH1322
Dependency failed for /home
Dependency failed for Local File Systems
Dependency failed for Remote File Systems (Pre)

2. I thought different hard disks are identified by different id. I found that though hard drives are identical (WD800BB + JHC0 whatever this is), serial numbers (i.e WMAM9DEH1322 above is serial num) are different. I saw fstab used the serial number:
/dev/disk/by-id/ata-WDC_WD800BB-00JHC0_WD_<serial number here>_part<x> <mount point> ...

3. Like I said, it can restore root partition but only when it tried to mount /home, it failed. So I booted the clone box using sysresccd and looked around, I found that /dev contains almost nothing. Normally, /dev will contains lots of files.

Based on my experience with Windows, Windows will regenerate necessary files and ids (i.e SID's) if I use proper tools (SysPrep) and steps. How can I do the same for the Linux? Or am I following the wrong lead? How do you solve this problem? Due to my requirement, I have to make /home as separate partition.

Thank you much!

Posts: 2
Joined: 16 Feb 2014, 23:03

Re: Restoring OpenSuSE Problem

Post by nexz » 17 Feb 2014, 09:00

Posted same question in OpenSuSE forum and things worked out. Basically, I did the following:

1. Edit /etc/fstab to have device names, i.e /dev/sda1, etc.
2. In /etc/default/grub, edit GRUB_CMDLINE_LINUX_DEFAULT to use device name instead of by-id thing
3. Ran grub2-mkconfig

The root cause being fstab is identifying partitions/hd with serial numbers. When you restore that image to another machine with different hd serial, you bumped into problems. Search using some text in numbered list in OpenSuSE forum if you want to look at discussions.


Post Reply