vncserver port:3389

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
knag1
Posts: 5
Joined: 02 Oct 2009, 17:29

vncserver port:3389

Postby knag1 » 02 Oct 2009, 17:37

First:
I was not able to fix that vncserver start display :1 on TCP port 3389 which is opened on a firewall for Windows RDP access. First I failed to change the menu.lst file enty
and second I tried to start within a autostart shell but without success. Can someone help?

Second:
vncserver did'nt start at all on V1.3.0 with the menu.lst entry!!!
V1.2.3 or older is ok.

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: vncserver port:3389

Postby admin » 04 Oct 2009, 21:31

the "vncserver" boot option has been fixed in SystemRescueCd-1.3.1. TightVNC has been replaced with TigerVNC, but it's very similar.
Please post more details about the other problems for help.

knag1
Posts: 5
Joined: 02 Oct 2009, 17:29

Re: vncserver port:3389

Postby knag1 » 05 Oct 2009, 10:46

Thank's for the reply. here are some details of my testings:

I tried with menu.list to use the following:

kernel /sysrcd/rescuecd subdir=sysrcd setkmap=de ethx=163.157.140.224/23 gateway=163.157.141.1 vncserver=3389:123456 docache
or
kernel /sysrcd/rescuecd subdir=sysrcd setkmap=de ethx=163.157.140.224/23 gateway=163.157.141.1 vncserver=3389::123456 docache
or
kernel /sysrcd/rescuecd subdir=sysrcd setkmap=de ethx=163.157.140.224/23 gateway=163.157.141.1 vncserver=-2511:123456 docache

anyway nothing worked to get vncserver corresponding on port 3389.

then I tried to start with a script "autorun0" but there I receive an error

#!/bin/bash
su root
user=root
mount /dev/sda1 /mnt/windows
cd /usr/bin
vncpasswd < /mnt/windows/sysrcd/pwd.txt
vncserver :1 -rfbport 3389
exit 0

the pwd.txt input file seems to work!
but the vncserer -rfbport 3389 fails with an error
like "user enivronment variable not set".

Any idea?

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: vncserver port:3389

Postby admin » 06 Oct 2009, 06:23

The first option of "vncserver=" is not the port number, it's the number of vnc session to create. So "vncserver=2:MyPassWd" will create two vnc session listening on 5901 and 5902, running as root, with the same password.

To use port 3389 you will have to either configure TigerVNC by hand (or using an autorun script), use iptables to redirect the port 3389 to 5901 with a DNAT, or something like tcppipe or netcat:

This example shows how to create a custom xinetd service to redirect port 3389 to 5901
Create a file in /etc/sysconfig/xinetd.d/ (call it what you want)

service redirect
{
flags = REUSE
protocol = tcp
socket_type = stream
port = 3389
wait = no
user = nobody
server = /usr/sbin/nc
server_args = -w 10 127.0.0.1 5901
disable = no
}

knag1
Posts: 5
Joined: 02 Oct 2009, 17:29

Re: vncserver port:3389

Postby knag1 » 08 Oct 2009, 16:39

Hi, This is a liitle too tricky for a linux novice like me!
But with the new TigerVNC I'm a little bit more lucky.
With the following autorun0 script vncserver is responding on port 3389

#!/bin/bash
{
mount /dev/sda1 /mnt/windows
cd /usr/bin
vncpasswd < /mnt/windows/sysrcd/pwd.txt
vncserver :1 -rfbport 3389
}
exit 0

... but there is just a blank screen displyed in vncviewer ip:3389
with selection possibilities in the upper left corner
x Accept clipboard for viewers
x Send clipboard to viewers
x Send primary selection to viewers

and I can move the curser X

But the script is waiting for ENTER!

after pressing ENTER
then sysrcd startup continues and I can see starting TigerVNC

at the end when I retype vncserver command manully then it works.

In my opinion autorun0 is starting too early, before the graphical part is ready for vncserver.

is it a possibility to change the startup script of sysrcd so that autorun scripts run at the end?


Return to “Boot problems”

Who is online

Users browsing this forum: No registered users and 1 guest