As of 4.1.0 automatic login on ttyS1 fails

Questions related to network booting via PXE
icorbett
Posts: 1
Joined: 23 Apr 2014, 14:48

As of 4.1.0 automatic login on ttyS1 fails

Postby icorbett » 23 Apr 2014, 15:09

This holds true for both version 4.1.0 and 4.2.0. It seems to work fine for version 4.0.1 and earlier.

I have been using the following pxe configuration for quite a while however on updating to the newer version of sysrescd automatic login started to fail:

Code: Select all

  kernel systemrescuecd/isolinux/rescue64
  append console=tty0 console=ttyS1,115200 dodhcp rootpass=pass setkmap=us initscript=sshd:start initscript=ipmievd:start initrd=systemrescuecd/isolinux/initram.igz netboot=http://192.168.0.6:8081/systemrescuecd/sysrcd.dat


This always results in the following on my console:
sysresccd login: root (automatic login)

Login incorrect

sysresccd login: root (automatic login)

Login incorrect
INIT: Id "s0" respawning too fast: disabled for 5 minutes
INIT: no more processes left in this runlevel


I have discovered that monitoring the boot process and quickly running this command via ssh does allow the automatic login to succeed:
ssh [email protected] '(echo ttyS1 > /etc/securetty)'


I assume this is likely also true for any other serial interface than ttyS0 but as ttyS1 is standard for my IPMI devices it is non-trivial for me to test others.

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: As of 4.1.0 automatic login on ttyS1 fails

Postby gernot » 24 Apr 2014, 14:55

I tested today with 4.2.0 rescue32 without problems.
(cant test 64 bit ant serial console at the moment)

Make sure rescue64 initrd sysresccd.dat and sysresccd.md5 come from the same version.

I just used this because ssh need only a password to work.

LABEL rescuecd_std
MENU LABEL 1) SystemRescueCd: default boot options
KERNEL ifcpu64.c32
APPEND rescue32 scandelay=5 netboot=http://192.168.1.5/sysrcd.dat passwd=pass

Gernot

zito
Posts: 5
Joined: 09 Oct 2007, 11:51

Re: As of 4.1.0 automatic login on ttyS1 fails

Postby zito » 19 May 2014, 15:09

Hi,
I have exactly the same problem :).
I tried to boot with the console on the com0 (ttyS0) within virtual host with virt-manager. It is easy to switch from a graphical console to the serial console. With ttyS0 it works. I think this can be because:

Code: Select all

[email protected] /root % tail -2 /etc/securetty
tts/0
ttyS0


I have IPMI on ttyS1 too. So I need boot with console on ttyS1.
Is it possible to insert ttyS1 into /etc/securetty?
Previous versions of System Rescue CD probably didn't check securetty?
Many thanks for great live distro!
--
Zito

zito
Posts: 5
Joined: 09 Oct 2007, 11:51

Re: As of 4.1.0 automatic login on ttyS1 fails

Postby zito » 19 May 2014, 15:31

Yes, it is really due to securetty.
I boot a Dell PE1950 server on DRAC management with console=ttyS1 and rootpass=bla.
I logged in using ssh afterwards and insert ttyS1 into securetty and voala:

Code: Select all

sysresccd login: root (automatic login)

Login incorrect
INIT: Id "s0" respawning too fast: disabled for 5 minutes
INIT: no more processes left in this runlevel

sysresccd login: root (automatic login)

Last login: Mon May 19 15:19:13 +0000 2014 on pts/0 from 10.0.156.89.
[email protected] /root % tail -3 /etc/securetty
tts/0
ttyS0
ttyS1


login succeded after a timeout period :).

So fix is very simple.
Thanks for your work!
Best Regards
--
Zito


Return to “Network Boot via PXE”

Who is online

Users browsing this forum: No registered users and 3 guests