Conflicting info regarding NFS support

Questions related to network booting via PXE
mcai8rw2
Posts: 2
Joined: 02 Jan 2013, 15:35

Conflicting info regarding NFS support

Postby mcai8rw2 » 02 Jan 2013, 15:46

Hello All,

I have a Windows Server 2008r2 server, which i have set up as a PXE server.

This server is correctly booting some linux distros at boot (TRK and others). I cannot get SYSTEMRESCUECD working though.

Having read the support docs, i am receiving conflicting advice on what syntax is correct for booting an NFS share.

Below is my sysrcd entry in pxelinux.cfg file:

Code: Select all

#---
 LABEL System Rescue CD X64
 menu label System Rescue CD X64
 KERNEL /linux/systemrescuecd/isolinux/rescue32
 [b]CHOICE1[/b]#---append netboot=nfs://192.168.XX.XX:/systemrescuecd root=auto
 [b]CHOICE2[/b]#---append nfsboot=192.168.XX.XX:/systemrescuecd root=auto
 #---


Please could you confirm which choice is correct for the NFS Share?

Finally ... upon booting a client via pxe I constantly receive the following error:

VFS: Cannot open root device "auto" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
0b00 1048575 sr0 driver: sr
kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


I have checked that the NFS share on Windows2008R2 has access to ROOT and also has read-write access.

Please could you tell me what the 'root=' option is and what i should be putting in here.

Many thanks for your time.

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: Conflicting info regarding NFS support

Postby gernot » 02 Jan 2013, 16:23

The correct syntax is "netboot=nfs://......

sysrcd need the initrd to boot. Have you such a line in your config?
INITRD initram.igz

Gernot

mcai8rw2
Posts: 2
Joined: 02 Jan 2013, 15:35

Re: Conflicting info regarding NFS support

Postby mcai8rw2 » 07 Jan 2013, 11:59

***Edit: Ignore me... i worked it out by removeing the "root=auto" part***

OOO! nice! Thanks Gernot. Adding the initrd line in nearly solved it :)

However, now i am receving a boot error:

Code: Select all

Searching for a root filesystem having /sbin/init
Attempting to mount device: /dev/sda
Attempting to mount device: /dev/sda1
Attempting to mount device: /dev/sda2
Cannot find device with /sbin/init
...
Cannot find a valid root filesystem (partition having /sbin/init)
Running a minishell (cannot complete the boot process).



Any further sage wisdom to impart my way?

Thanks again.

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: Conflicting info regarding NFS support

Postby gernot » 07 Jan 2013, 16:26

Look like the "root=auto" option is present.
use "cat /proc/cmdline" in the minishell to examine the boot command line.

Gernot


Return to “Network Boot via PXE”

Who is online

Users browsing this forum: No registered users and 1 guest