PXE boot problem: SQUASHFS error:Filesystem uses "lzma"compr

Questions related to network booting via PXE
Marcin
Posts: 3
Joined: 10 Jan 2011, 09:40

PXE boot problem: SQUASHFS error:Filesystem uses "lzma"compr

Postby Marcin » 10 Jan 2011, 12:35

Hi!
I've got PXE server configured in that way:
first pxelinux.cfg has entry:

Code: Select all

MENU LABEL SystemRescueCD
        CONFIG 192.168.138.254::pxelinux/obrazy/systemrescuecd/isolinux/isolinux.cfg
        APPEND 192.168.138.254::pxelinux/obrazy/systemrescuecd/isolinux/


isolinux/isolinux.cfg is original cfg from iso with netboot=//http://..... appended to each entry.
Kernel loads correctly, get sysrcd.dat but can't mount it with message about LZMA.
This problem is with sysrescuecd-2.0.0. if i get kernel (rescuecd - 32bit) from systemrescuecd-1.6.4, everything works correctly.
Could it be problem with my configuration?
Regards.

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: PXE boot problem: SQUASHFS error:Filesystem uses "lzma"c

Postby gernot » 10 Jan 2011, 15:50

Tried you also the onbord pxebootserver?
I wonder you write sysrcd.dat.
It is the initrd who is lzma compressed while sysrcd.dat is a squashfs image.

Get you a restricted shell or blinking keybordleds?

Gernot

Marcin
Posts: 3
Joined: 10 Jan 2011, 09:40

Re: PXE boot problem: SQUASHFS error:Filesystem uses "lzma"c

Postby Marcin » 10 Jan 2011, 20:48

No, i didn't tried onboard pxebootserver. I would like to setup own pxe serving a few, diffrent systems. And i'm doing it on working host. I didn't change any file from systemrescuecd, beside isolinux.cfg.
I'm getting restricted shell, busybox as i remeber.
It looks for me, that kernel can't handle sysrcd.dat, but i don't know why. Booting from cdrom works perfectly, the same files are sending via tftp (sysrcd.dat is sending via http).
Argh, http... Probably I know what is the problem, i didn't change config of http server. It sends image from version 1.6.4. I'll check it tomorrow, but i'm sure for 99% that all this problem is my mistake with it.
Thank you for reply.

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: PXE boot problem: SQUASHFS error:Filesystem uses "lzma"c

Postby gernot » 10 Jan 2011, 21:08

Yes a old sysrcd.dat can be the problem.
Check http://www.sysresccd.org/Changes-x86 :
"The squash filesystem is now compressed using XZ instead of LZMA"

Gernot

Marcin
Posts: 3
Joined: 10 Jan 2011, 09:40

Re: PXE boot problem: SQUASHFS error:Filesystem uses "lzma"c

Postby Marcin » 11 Jan 2011, 09:09

Yes, http server sends sysrcd.dat version 1.6.4.
Now, everything works correctly. Sorry for noise and thanks for help!
Regards.


Return to “Network Boot via PXE”

Who is online

Users browsing this forum: No registered users and 2 guests