Page 1 of 1

Latest SRCD lacks current hyper-v linux modules

Posted: 20 Jul 2018, 15:36
by gyles19
I've been using SRCD for years in our Hyper-V/Ubuntu guest environment. Recently I discovered that SRCD not longer functions properly with the Gen2 Ubuntu Guests, it boots, but once it drops to a command prompt it fails to detect any of the guests's filesystems, and there is no functional keyboard. As far as I can tell, the required hyper-v drivers for Gen-2 guests are simply not present. I can boot the VMs from an Ubuntu installer ISO image. I even tried making the SRCD ISO image a grub selection (with the iso image present on the boot partition) but that failed as well.

It seems like this project is dying, as new-user registration here on the forum is disabled. Luckily I found an old account I had once created still functioned so I can post this.

Using the ubuntu installer for system rescue just sucks. Is there an alternative project I should move to?

I don't want to waste my time creating a custom boot for SRCD if this is the last version. Can anyone provide guidance?

Re: Latest SRCD lacks current hyper-v linux modules

Posted: 02 Sep 2018, 22:54
by nickalreadytaken
Have you tried the latest beta?

Re: Latest SRCD lacks current hyper-v linux modules

Posted: 05 Sep 2018, 20:44
by gyles19
Thank you for the reply. I saw the new release announcement from SourceForge yesterday and cheered!

However, I just downloaded 5.3.0 and attempted to boot a hyper-v Gen 2 Ubuntu 16.04 VM with it, and it behaves the same as the previous release of SRCD. It finds grub, but it can't find any disks or filesystems and there is no functional keyboard. I can boot this vm fine with the Ubuntu Live CD in rescue mode. I still suspect the custom kernel is lacking the required hyper-v drivers. A functional VM has the following hv_* stuff loaded after boot:

hv_balloon 24576 0
hv_storvsc 20480 3
scsi_transport_fc 65536 1 hv_storvsc
hv_netvsc 40960 0
hv_utils 28672 0
ptp 20480 1 hv_utils
hv_vmbus 90112 7 hv_balloon,hyperv_keyboard,hv_netvsc,hid_hyperv,hv_utils,hyperv_fb,hv_storvsc

This is from kernel 4.4.0-130-generic on a similar VM. Most of these drivers are built-in on the Ubuntu distros kernels. Is there anything I can do to assist you with fixing this? I haven't (yet) attempted to build a custom kernel and burn a private version of SRCD, having enough work on my inbox to keep three clones of me busy already...

I've been ordered to migrate all of our linux vms to hyper-v gen2 with secure booting so this is becoming more pressing. If there is anything I can do to help address this, please let me know.

Re: Latest SRCD lacks current hyper-v linux modules

Posted: 13 Sep 2018, 05:14
by nickalreadytaken
Unfortunately I can not help, as I do not maintain the CD. I hope, that Francois does pickup this topic.

Have you tried to build a custom SystemescueCd? ... wn_kernel/

Re: Latest SRCD lacks current hyper-v linux modules

Posted: 21 Sep 2018, 17:07
by nickalreadytaken
Release 5.3.1 is out since a few days.