UEFI boot ignoring vga= kernel parameter

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
vanepp
Posts: 86
Joined: 22 Jun 2012, 02:24

UEFI boot ignoring vga= kernel parameter

Postby vanepp » 17 Feb 2016, 04:11

I'm trying to set the video resolution to vga=769 (640*480*8) for a backup script using dialog on 4.7.1. While this works fine for non UEFI boot (using the /mnt/custom/customcd/isoroot/isolinux/isolinux.cfg file) it doesn't seem to work when I modify /mnt/custom/customcd/isoroot/boot/grub/grub-471.cfg (which seems to be the UEFI config) to add it like this:

menuentry "SystemRescueCd (64bit, default boot options)" {
linux /isolinux/rescue64 docache nonet nonm nodhcp setkmap=us nomodeset vga=769
initrd /isolinux/initram.igz

While this boots, the screen resolution is set to something like 1024*768 rather than the desired 640*480. As well (as noted elsewhere) the no networking parameters also don't work any more, this happily obtains and activates a DHCP network connection (which it didn't in past versions). Can someone tell me what I need to do to get the video mode set to 640*480 for UEFI please?

Peter Van Epp

Return to “Boot problems”

Who is online

Users browsing this forum: No registered users and 3 guests