Boot waits for a keystroke before autoruns are processed.

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
Sfor
Posts: 3
Joined: 16 Oct 2015, 11:15

Boot waits for a keystroke before autoruns are processed.

Postby Sfor » 16 Oct 2015, 11:54

I'm trying to add some autorun scripts to a PXE boot. In general I'm adding ar_source=smb://xxxxxx ar_nowait to the kernel boot options. But, the SysRescueCD stops for an Enter key before the scripts are processed. So there is no meaning to the ar_nowait option. The boot process does not stop after autorun with ar_nowait. But, it stops before autorun, no mater if ar_nowait is present or not.

The key press wait is present in both 4.5.2 and 4.6.0 versions. I tried with PXE and USB booting with the same result. All the kernel versions seems to be affected, as well.

Is the wait for key stroke before the autorun an intended feature?
If so, is there a simple way to get arond it?

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: Boot waits for a keystroke before autoruns are processed

Postby gernot » 17 Oct 2015, 08:02

I checked the source and find only one "prompt" statement after all ar scripts executed.
ar_nowait work for this prompt after all autorun scripts processed.

Get you a other prompt?
What is the last message before the script stop?

Is it possible that your own ar_script wait.

What happens if you try to run /usr/sbin/autorun manual.
Try to Mount and run your script manual and check how it work.

Gernot

Sfor
Posts: 3
Joined: 16 Oct 2015, 11:15

Re: Boot waits for a keystroke before autoruns are processed

Postby Sfor » 18 Oct 2015, 12:40

Using: SYSTEM-RESCUE-CD 4.5.2
altker32 scandelay=5 netboot=http://192.168.xxx.xxx/sysrcd.dat setkmap=pl vncserver=2:rtrtrt rootpass=rt dodhcp ar_source=smb://server/backup ar_nowait

First experiment.

The autorun script has just one line in it: mkdir /root/sysbkup

The last message on the console is: Initializing autorun...

After logging in through SSH I see no sysbkup folder.

Hitting the Enter on the console.

The sysbkup folder got created.

Second experiment.

The last message on the console is: Initializing autorun...

logging in through SSH...

the /usr/sbin/autorun does nothing

I can not find the autorun file in the /usr/sbin folder

Hitting Enter on the console... seems the script has been run...

Yup, there is the /root/sysbkup folder.

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: Boot waits for a keystroke before autoruns are processed

Postby gernot » 18 Oct 2015, 15:31

Ok. now found the problem, but no solution.

if you call /usr/sbin/autorun you get the answer...

The smb mount ask for a password:

Code: Select all

Initializing autorun...

Password for [email protected]//192.168.178.20/pub/test.txt:



Gernot

Sfor
Posts: 3
Joined: 16 Oct 2015, 11:15

Re: Boot waits for a keystroke before autoruns are processed

Postby Sfor » 19 Oct 2015, 08:20

I think there is a possible work around available.

First is to use http instead of smb to call the autorun. Since the http is used in the netboot, there is no reason to hold back in my case. However it could be a problem for others.

There is also a possibility to use autorun from http or from other source to mount smb share and then to launch other autoruns from there. It should be possible to provide the smb mounting with the password that way.

------------------------

I've noticed the SystemRescueCD tries to download autoruns from 0 to F. I dont recall the A-F range on the english manual pages in the boot options section. There is just the [0-9] range, as far as I remember.

-------------------------------------

For the mount to work without a password on an smb share the -o guest option is necesary.

Is it a right thing to assume the smb share mount fom ar_source switch is without password, since there is no way to pass the password?

If so, adding -o guest option would be a logical thing to do.

If not, a prompt asking for a password would be a logical improvement, since there is no prompt, now.

Perhaps the best solution would be to try to mount the share with the -o guest option, first. Then to prompt for a password, once the mount as guest fails.


Return to “Boot problems”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests