Customized grub boot menu not in new iso image [solved]

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
rodwright
Posts: 6
Joined: 03 Mar 2015, 20:19

Customized grub boot menu not in new iso image [solved]

Postby rodwright » 10 Mar 2015, 00:45

I want to be able to efi boot my customized SystemRescueCD-4.5.1 with the same options I have in my isolinux.cfg file. I edited my /mnt/custom/customcd/isoroot/boot/grub/grub-451.cfg file to include the desired boot parameters. After I generate the new iso, I can loop mount it and boot/grub/grub-451.cfg contains my changes. If I then burn the iso to a CD and boot it, the grub menu comes up without my changes. After it boots, I cd to /livemnt/boot/boot/grub and look at the grub-451.cfg file and my changes are gone.

I can edit the boot parameters in the grub menu during boot and everything happens as expected. I just can't make them stick. I suspect I'm missing a step, but I'm not sure what. At what point in the boot process do my changes get lost? Do I need to grub-install, and if so, what should it's device parameter be?
Last edited by rodwright on 10 Mar 2015, 18:04, edited 1 time in total.

rodwright
Posts: 6
Joined: 03 Mar 2015, 20:19

Re: Customized grub boot menu not included in new iso image

Postby rodwright » 10 Mar 2015, 18:03

D'oh! I screwed it up. It turns out that editing my /mnt/custom/customcd/isoroot/boot/grub/grub-451.cfg file did work. And I would have known that if I had only burned the correct iso file to the disc!

Oh, well...


Return to “Boot problems”

Who is online

Users browsing this forum: No registered users and 3 guests