[x86 4.4.1] skipmount doesn't work

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
adigulla
Posts: 4
Joined: 31 Dec 2014, 11:02

[x86 4.4.1] skipmount doesn't work

Postby adigulla » 31 Dec 2014, 11:13

I'm using systemrescuecd-x86-4.4.1.iso

Installing and using your product has been a nice experience so far, thank you for the amount of effort and love that you invested.

I have set up a PC where I wipe old hard drives. Sometimes, I have to abort the wipe and reboot.

If that happens, then one of the drives has no partition tables and that leads to the problem described here: sysrcd tries to find a partition table, scans the whole disk and that takes several hours.

So I tried to the fix as suggested by the post:

1. Booting
2. Press TAB to edit the boot options while the first item in the list is selected (the default)
3. Appending " skipmount=/dev/sdc" to the options which are already there
4. ENTER to start booting

But sysrcd still tries to mount /dev/sdc :-(

Questions:

1. Did I do something wrong with the steps above or is this a bug?
2. Can you please add a timeout to the mount? I would really prefer the process to try to mount for a couple of seconds (say 10) and then ask whether it should continue or skip this drive.

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: [x86 4.4.1] skipmount doesn't work

Postby gernot » 31 Dec 2014, 15:25

Try to select 32/64 bit manual.
In case you boot automatic the skipmount option must be on the used side after the ifcpu64 command.

A workaround is to boot from CD in such a case. The CD is scanned as first device.

Gernot

adigulla
Posts: 4
Joined: 31 Dec 2014, 11:02

Re: [x86 4.4.1] skipmount doesn't work

Postby adigulla » 01 Jan 2015, 16:06

gernot wrote:Try to select 32/64 bit manual.


Option "C", I presume?

gernot wrote:In case you boot automatic the skipmount option must be on the used side after the ifcpu64 command.


Or "before the -- if you have a 64bit CPU."

I tried this and it solves my problem. Thank you :-)

I have some ideas how to improve this part. Is there a way to file a feature request?

Regards,

A. Digulla


Return to “Boot problems”

Who is online

Users browsing this forum: No registered users and 4 guests