Problem booting SystemRescueCD from multiboot usb

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
kuroneko
Posts: 4
Joined: 30 Jun 2011, 22:30

Problem booting SystemRescueCD from multiboot usb

Postby kuroneko » 30 Jun 2011, 22:46

Hi

I created a multiboot USB with Knoppix DVD and SystemRescueCD using MultiSystem, which says it supports both (http://liveusb.info/dotclear/index.php?pages/os). For those of you not familiar with it, MultiSystem basically installs the liveCD onto the USB and adds the grub menuentry. Knoppix works fine. The problem is when I try to boot sysreccd, it complains about not being able to find sysrcd.dat and kicks me to a minishell. I've confirmed that it is not detecting my USB for some reason. /proc/partitions shows only sr0 and sda, sda being my hard drive, and it only attempts to mount /dev/sr0 and /dev/sda[1-6] when it's looking for sysrcd.dat

The menuentries in grub.cfg:

Code: Select all

menuentry "SystemRescueCd 32bit" {
linux /systemrescuecd/isolinux/rescuecd rootfs=/systemrescuecd subdir=systemrescuecd dostartx setkmap=us scandelay=4
initrd /systemrescuecd/isolinux/initram.igz
}
menuentry "SystemRescueCd 64bit" {
linux /systemrescuecd/isolinux/rescue64 rootfs=/systemrescuecd subdir=systemrescuecd dostartx setkmap=us scandelay=4
initrd /systemrescuecd/isolinux/initram.igz
}


I'm not too familiar with linux kernels and modules, but maybe it has to do with the kernel not loading usb device modules or something? Are the boot options right (rootfs, subdir, etc.)?

gernot
Posts: 1112
Joined: 07 Apr 2010, 16:19

Re: Problem booting SystemRescueCD from multiboot usb

Postby gernot » 01 Jul 2011, 04:33

Work sysrcd with its own USB installer?
Maybe the multiboot driver "lock" the USB hardware.

try "dmesg|grep usb" from the minishell to get more informations.
lsmod shold show the module usb_storage.

I think you dont need rootfs because all partitions are scanned.

Gernot

kuroneko
Posts: 4
Joined: 30 Jun 2011, 22:30

Re: Problem booting SystemRescueCD from multiboot usb

Postby kuroneko » 01 Jul 2011, 22:10

dmesg | grep usb:

Code: Select all

[    0.909696] usbcore: registered new interface driver usbfs
[    0.909815] usbcore: registered new interface driver hub
[    0.909942] usbcore: registered new device driver usb
[    3.071233] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    3.071352] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.071511] usb usb1: Product: EHCI Host Controller
[    3.071613] usb usb1: Manufacturer: Linux 2.6.38-std220-amd64 ehci_hcd
[    3.071717] usb usb1: SerialNumber: 0000:00:1a.0
[    3.086220] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
[    3.086325] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.086482] usb usb2: Product: EHCI Host Controller
[    3.086583] usb usb2: Manufacturer: Linux 2.6.38-std220-amd64 ehci_hcd
[    3.086688] usb usb2: SerialNumber: 0000:00:1d.0
[    3.095145] usbcore: registered new interface driver usbhid
[    3.095247] usbhid: USB HID core driver
[    3.374026] usb 1-1: new high speed USB device using ehci_hcd and address 2
[    3.488572] usb 1-1: New USB device found, idVendor=8087, idProduct=0024
[    3.488716] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    3.591977] usb 2-1: new high speed USB device using ehci_hcd and address 2
[    3.706401] usb 2-1: New USB device found, idVendor=8087, idProduct=0024
[    3.706546] usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    3.771168] usb 1-1.4: new high speed USB device using ehci_hcd and address 3
[    3.857571] usb 1-1.4: New USB device found, idVendor=0408, idProduct=2fb1
[    3.857713] usb 1-1.4: New USB device strings: Mfr=3, Product=2, SerialNumber=0
[    3.857873] usb 1-1.4: Product: Laptop_Integrated_Webcam_2HDM
[    3.857972] usb 1-1.4: Manufacturer: CN07CN2C7866414M1F2EA00
[    3.982105] usb 2-1.2: new low speed USB device using ehci_hcd and address 3
[    4.071526] usb 2-1.2: New USB device found, idVendor=04b3, idProduct=310c
[    4.071530] usb 2-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[    4.071533] usb 2-1.2: Product: USB Optical Mouse
[    4.073730] input: USB Optical Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input6
[    4.073840] generic-usb 0003:04B3:310C.0001: input,hidraw0: USB HID v1.11 Mouse [USB Optical Mouse] on usb-0000:00:1d.0-1.2/input0
[    4.147043] usb 2-1.5: new full speed USB device using ehci_hcd and address 4
[    4.237033] usb 2-1.5: New USB device found, idVendor=8086, idProduct=0189
[    4.237043] usb 2-1.5: New USB device strings: Mfr=0, Product=0, SerialNumber=0


lsmod | grep usb shows nothing. Is there a way to force grub/systemrescuecd/linux kernel to load usb_storage?

kuroneko
Posts: 4
Joined: 30 Jun 2011, 22:30

Re: Problem booting SystemRescueCD from multiboot usb

Postby kuroneko » 02 Jul 2011, 04:38

I sort of got it working now. My laptop has two USB 3 slots and one USB/eSATA combo slot. SystemRescueCD boots when the USB is in the USB/eSATA slot. Some compatibility issues with USB 3 slots? Anyway, after booting, I try to mount my external hard drive (plugged into one of the other USB 3 slots), and the drive mounts as read-only. I plan on using SystemRescueCD to backup to my external hard drive, so I still need to get this to work. How's SystemRescueCD's support for USB 3 slots?

gernot
Posts: 1112
Joined: 07 Apr 2010, 16:19

Re: Problem booting SystemRescueCD from multiboot usb

Postby gernot » 02 Jul 2011, 08:23

The usb 3.0 driver xhci-hcd is in sysrcd.dat but not in the initrd.
You can just for testing save this module at a accessible place and load it from the minishell.

A workaround is to store sysrcd.dat and sysrcd.md5 on a harddisk partition in "$subdir".

About the readonly filesystem: Used you mount for a NTFS formated partition? Using ntfs-3g instead of mount helps.

Gernot

kuroneko
Posts: 4
Joined: 30 Jun 2011, 22:30

Re: Problem booting SystemRescueCD from multiboot usb

Postby kuroneko » 02 Jul 2011, 08:46

Looking at this http://www.sysresccd.org/forums/viewtopic.php?f=14&t=4137, I'm guessing it is a problem with USB 3.0. As SystemRescueCD isn't viable for my back up purposes, I picked up CloneZilla instead, which works perfectly. I look forward to when sysreccd supports USB 3, it has a bunch of useful tools.


Return to “Boot problems”

Who is online

Users browsing this forum: No registered users and 2 guests