noload=dmraid not working How to disable dmraid -ay?

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
tooke
Posts: 2
Joined: 11 Oct 2009, 16:14

noload=dmraid not working How to disable dmraid -ay?

Postby tooke » 11 Oct 2009, 16:17

I am trying to boot and keep getting hung on the dmraid -ay step, while it keeps trying my damaged drive.
I have tried rescuecd noload=dmraid and
skipmount=/dev/sda (my damaged drive), but each time, it still loads this step. Any suggestions?
Thanks

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: noload=dmraid not working How to disable dmraid -ay?

Postby admin » 11 Oct 2009, 20:12

dmraid is not a kernel module so it does not work. You have to boot with option "nodmraid"

tooke
Posts: 2
Joined: 11 Oct 2009, 16:14

Re: noload=dmraid not working How to disable dmraid -ay?

Postby tooke » 12 Oct 2009, 11:52

Thanks alot, I'll give it a try.

xiko
Posts: 1
Joined: 08 Nov 2009, 01:01

Re: noload=dmraid not working How to disable dmraid -ay?

Postby xiko » 08 Nov 2009, 01:09

I have a driver with bad blocks. I had to do rescuecd nodmraid nomdadm for it to keep loading

Setting up the Logical Volume Manager had some "/dev/sda1: read failed after 0 of 4096 at #########: Input/Output error but he kept going.

If this works I would suggest to add this to either the boot options or the help so we can load the rest of linux. Im trying to recover some files from the hd (it is a notebook here).

I will update this thread to tell if I could make it or not.

Hmm without those happening I cant see my hd and the recover tool doesnt see it as well. sigh.

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: noload=dmraid not working How to disable dmraid -ay?

Postby admin » 08 Nov 2009, 09:06

Thanks, these options have been added to the documentation


Return to “Boot problems”

Who is online

Users browsing this forum: No registered users and 1 guest