Can't boot with Virtual PC

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
Post Reply
Posts: 1
Joined: 20 Jul 2007, 21:00

Can't boot with Virtual PC

Post by virtualpc » 21 Jul 2007, 13:51


I'm using Virtual PC 7 on a Mac G5. I had previously used SystemRescueCd to archive my legacy pcs into Vitrual PC using nc and dd. Now I am trying to get these out of Virtual PC and into VMWare since Virtual PC is abandonware on the Mac.

My problem is that I cannot get any version of SystemRescueCD to fully boot to a command prompt with working networking (second issue).

Version 0.3.6:

After hitting enter to select the default keymap I get tons or errors and the last stuff I can see on my screen is a bunch of segfaults while running shell scripts. I see errors in /sbin/rc, /lib/rcscripts/sh/, /sbin/, /sbin/

I do get to a login prompt but cannot login.

Version 0.2.19:

With this version, after I select the default keymap it says it is mounting the device, then a see a ton of I/O errors involving cloop and hdc (the emulated cd drive). At the end I get a kernel panic (Attempted to kill init!)

Version 0.2.12:

With this version, after I select the default keymap I get errors "Copying and symlinking files from CD to populate /", and finally a kernel panic.

I have tried various settings like "acpi=off", "noapic", "ide=nodma" without success. I have also tried using a physical copy of the cd instead of the emulated file and I get the same errors.

Any suggestions?

Post Reply