Boot freeze

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
Post Reply
skullmunky
Posts: 1
Joined: 21 Jul 2007, 03:49

Boot freeze

Post by skullmunky » 21 Jul 2007, 04:02

using systemrescuecd 0.3.7.

this disk boots and runs fine on one machine, but is freezing on another very similar one. they have different motherboards; the one that's freezing is a Gigabyte K8Vt890-9 (VIA chipset). it gets to the boot screen, i can choose a kernel and options, it starts booting, and freezes right after detecting the drives. last messages look like this:

Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:0f.1
PCI: Assigned IRQ 11 for device 0000:00:0f.1
PCI: VIA VLink IRQ fixup for 0000:00:0f.1, from 255 to 11
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8237 (rev 00) IDE UDMA133 controller on pci0000:00:0f.1
ide0: BM-DMA at 0xe800-0xe807, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at oxe808,0xe80f, BIOS settings: hdc:pio, hdd:pio

CD-ROM is on the first IDE bus; hard drive is an SATA, which comes up as IDE2 at boot.

i've tried all the usual kernel parameters (noapic, acpi=off, ide=nodma, nodetect, etc) to no avail. i've tried disabling IDE DMA in the bios, disabling IDE1 in the bios, unplugging and disabling the SATA bus completely, all to no avail. what else can i do??

pete.dawgg
Posts: 45
Joined: 29 Nov 2006, 13:31
Location: /dev/kmem

chipset?

Post by pete.dawgg » 30 Jul 2007, 10:07

do you by any chance happen to have a recent (965+) intel-chipset? they don't have any "real" ide-controllers anymore (or sth like that), but if you append the kernel-boot-parameter

Code: Select all

all-generic-ide
it might work (helpled me a couple of times)

Post Reply