[Solved] Not Bootable nor usable

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
markmarques
Posts: 85
Joined: 26 Feb 2007, 12:30
Contact:

[Solved] Not Bootable nor usable

Post by markmarques » 26 Feb 2007, 14:04

Only recently have got a laptop to repair where I could not have SystemRescueCD to even boot.
The Laptop is a single core Intel Centrino M with an QSI DVD/RW combo.
No matter what I do with systemRescuedCD I got several (strange 7) keyboard errors before the "boot:" prompt.
the keyboard responds correctly except for the "F" keys but no matter what option I make it reports with "no image found"...
Usually I try the nofb option ...
The "startup image" sometimes becomes garbled...
As a side note: the Knoppix live CD does report keyboard errors at startup, but it boots correctly.
Other live Cds like Ubuntu work flawlessly ...
Tried with several versions of RescuesystemCD... from 0.2.9a to 0.3.3beta2
Any ideas ?
Or am I being dumb ?
Last edited by markmarques on 02 Jul 2007, 17:44, edited 1 time in total.

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Post by admin » 26 Feb 2007, 15:46

That's a strange problem. Are you able to use the USB version on your laptop ?
http://www.sysresccd.org/Sysresccd-manu ... _USB-stick

Can you boot the gentoo-livecd-2006.1 ?
ftp://ftp.proxad.net/mirrors/ftp.gentoo ... 2006.1.iso

markmarques
Posts: 85
Joined: 26 Feb 2007, 12:30
Contact:

Post by markmarques » 26 Feb 2007, 16:15

Hi...
I forgot something and the problem was already reported in a another thread:

http://www.sysresccd.org/forums/viewtopic.php?t=1215

I do have booted with several distros, some report the Keyboard errors other do not but almost all got past that point...
I forgot to mention that the motherboard is a OEM BL-50 laptop.
Any other hints or ideas ?

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Post by admin » 26 Feb 2007, 16:25

Yes, this problem cannot be related to the kernel, since this is before the kernel is loaded. The only program sunning is isolinux.bin, and the version is up to date. I have really no idea about what to do. Try the gentoo livecd an tell me.

markmarques
Posts: 85
Joined: 26 Feb 2007, 12:30
Contact:

Post by markmarques » 27 Feb 2007, 09:42

Made the simple test with simple Live CD Gentoo2005.1 and 2006.1 .
No problem whatsoever... :(
Both with full or without framebuffer... (nofb) ...
Everything worked perfectly....

Although other live bootCDs do report keyoard errors but are able to continue loading further.
As an adenda the mainboard is a BCL50 OEM and the graphic board is an 64Mb ATI mobile.
I did have found an old systemRescue CD 0.2.15 with the same problem...

I have found in the forum that sometimes it is required to specificy the full path of the linux image ...
How can I find out what to look for ? How can I know which dir at boot time ?
Sorry for my dumbness but which commands are available at boot prompt ?

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Post by admin » 27 Feb 2007, 10:04

Are you sure this is not due to a bad cdrom media ? With several CD drivers, there are discs that can't be read successfully, and of course the software can't work from this media. Please, test SysRescCd on a new CD-R / CD-RW.

markmarques
Posts: 85
Joined: 26 Feb 2007, 12:30
Contact:

Post by markmarques » 27 Feb 2007, 10:57

Already rule that (media / Burning) hipotesis out...
Tried several CDRW and CDs...
It works perfectly on other machines...On all the medias....
So it is not media problem. :)
I have found an old post where some had this kind of problem , also on a LapTop ad solved it by calling the full image path ...
I tried to copy the text exactly but the new 0.3.3beta 5 version did not work ...
Any other ideas ?
Is there any way to "list" or read anything at the "boot:" prompt before the call of the image ?
As a side note: an USB pen with system0.3.3beta5 boot works correctly still reporting keyboard errors. Havent tried any util after that experiment though...

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Post by admin » 27 Feb 2007, 11:42

1) Could you give me an example of an isolinux.cfg file with full paths ?

2) I have another idea: the way the isolinux.cfg is formatted. Could you try version 0.3.3-rc2 ?
This version has a new format (spaces instead of tabs), and I suppose it may fix the troubles.

3) Can you boot GParted-LiveCd-0.3.3-7 ? (You can ignore this step if version rc2 works well)
https://sourceforge.net/project/showfil ... _id=489228

Thanks for your tests

markmarques
Posts: 85
Joined: 26 Feb 2007, 12:30
Contact:

Post by markmarques » 28 Feb 2007, 09:31

Try both isos with the same problem... :(
Although GpartedLive does only report only one error
"Unknown keyord on config File" where RescueCD does have about 7 .
Gparted reports after: "Could not find kernel image : fb800" and then keeps trying to load that bootimage...
SystemRescue does report the same "could not find kernel image" but it only tried to load it once.
In both tests I can write in the boot: prompt .
Any more ideas ?

markmarques
Posts: 85
Joined: 26 Feb 2007, 12:30
Contact:

Post by markmarques » 28 Feb 2007, 09:42

oops ..
One of the images I tried where 0.3.3 rc1 ...
I will try the new 0.3.3rc2 in a moment.

markmarques
Posts: 85
Joined: 26 Feb 2007, 12:30
Contact:

Post by markmarques » 28 Feb 2007, 10:09

Tested with the 0.3.3rc2 , same problem ... :(
Several "unknown keyword in config file" and no chance to continue to boot...
it seems that it is not able to interpret something in the config file.

As a side note, does the splashscreen have the "Hardaware" word error on purpose ?

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Post by admin » 28 Feb 2007, 11:06

I removed several optional keys in the file. Could you test this version please ?
http://cdbeta.dupoux.org/testiso02.iso

I don't understand your question related to splashscreen sorry. Do you think it could work if I remove the splashscreen ?

markmarques
Posts: 85
Joined: 26 Feb 2007, 12:30
Contact:

Post by markmarques » 28 Feb 2007, 11:16

After some digging at the forum I found this:

http://www.sysresccd.org/forums/viewtopic.php?t=1161

Afterwards I and after reading the previous
Reading externally the isolinux.cfg file and calling the full path i passed the boot: prompt... writing down in paper the full nofb line ...
it becomes awkward having to write that full line... :(
Any ideas ?

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Post by admin » 28 Feb 2007, 11:56

Thanks for these details. You are right we must test with full paths. I added full paths in this ISO:
http://cdbeta.dupoux.org/testiso03.iso

But on the other hand, gentoo-livecd works well, and it does not use full paths...

markmarques
Posts: 85
Joined: 26 Feb 2007, 12:30
Contact:

Post by markmarques » 28 Feb 2007, 12:00

Tested the previous refering iso...
Still with no sucess .... :(
if i try "/isolinux/linuz1 it starts to boot but it reports Kernel panic afterwards due to the lack of the root option...
Somehow in the forum someone refered that old 0.2.15 version did worked correctly.

I do not know how but I retested the plain Gentoo2006.1 without any problem.
The problem is that somehow in the boot: prompt it only validates the "vmlinuz1" or memdisk as command ...

Regarding the splashscreen it has a typo in "Hardaware autodetection" ... :)

Post Reply