can't get rescue CD to boot on Winbook notebook computer

Post in this forum for problems at boot time, if there was no problem for burning the disc. For example can't find the CD, or strange errors when you press enter at the very first prompt.
Post Reply
Posts: 1
Joined: 08 Jun 2006, 14:47

can't get rescue CD to boot on Winbook notebook computer

Post by jkristofits » 08 Jun 2006, 17:25

I just recently found the systemrescuecd and tested it on a desktop PC to partition the
hard drive to make an existing XP system dual boot. It worked great. I just received my
new notebook (a WinBook W245) and tried to boot the CD, and it wouldn't boot, I get
the error "Unknown keyword in config file." and then the "boot:" prompt. I searched the
net and found that Fedora Core 5 has a bug that generates this error and the fix was
to pass the boot prompt a boot string. I passed it the following boot string:

/isolinux/vmlinuz1 initd=/isolinux/initrd1

and I then get the error:

VFS: Cannot open root device "<NULL>" or unknown-block(8,8 )
Please append a correct "root=" boot option
Kernel panic - not sycning: VFS: Unable to mount root fs on unknown-block(8,8 )

I then tried:

/isolinux/vmlinuz1 initd=/isolinux/initrd1 root=/newroot

and I get the keymap menu. I select my keymap (41) and then when it tries to boot,
I get the following error:

Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy.
VSF: Insert root floppy and press ENTER

I do not have a floppy on this notebook. Anyone else ever run into a problem like this?
Any help would be greatly apprieciated.


Posts: 2
Joined: 24 Jun 2006, 21:59

Problem solved

Post by xstatic » 24 Jun 2006, 22:16

Hey, John. I too have a Winbook and had the same problem with both SysRCD and FC5. For SysRCD, basically I just looked in the /syslinux/syslinux.cfg file and just typed in the full path at the boot: prompt like so:

Code: Select all

/isolinux/vmlinuz1 initrd=/isolinux/initrd1 root=/dev/ram0 init=/linuxrc vga=791
which made it boot up perfectly with FrameBuffer support at 1024x768 resolution.

I am not sure if this is a kernel bug or just a miswritten config file (or both). Hope this helps...

Posts: 1
Joined: 20 Sep 2006, 11:27

Post by pme127 » 20 Sep 2006, 13:51

On my current laptop Using code:
/isolinux/vmlinuz1 initrd=/isolinux/initrd1 root=/dev/ram0 init=/linuxrc vga=791

gets things moving up to:
/bin/sh: can't access tty; job control turned off / #

What do I do now? :(

However, I have an old laptop running Win95a 24MB memory 500MB HD which only has Floppy drive and I whant to run System Rescue, or at least the partitioning tools on bootable floppies, how do I create the floppies from the CD on another machine?

Thanks in antispation

Post Reply