Xorg support for Aspeed AST2400 VGA controller [solved]

You can report problems, make suggestions, about the new BETA versions in this forum. For stuff related to final releases, please post a message in other forums
Patsiecki
Posts: 2
Joined: 27 Jul 2014, 17:17

Xorg support for Aspeed AST2400 VGA controller [solved]

Postby Patsiecki » 27 Jul 2014, 18:03

I'm running a few servers on the Supermicro X10SLL-F motherboard (http://www.supermicro.com/products/motherboard/Xeon/C220/X10SLL-F.cfm) which uses the Aspeed AST2400 VGA controller (http://www.aspeedtech.com/products.php?fPath=20&rId=376). It seems my older Supermicro boards work fine as they are running on Matrox graphics, it looks like the manufacturer switched to Aspeed controllers with the newest generation boards. Unfortunately this poses a problem to me as the included version of X.org in all versions of rescueCD to date cannot launch into GUI session with this new controller. Tried using commands startx as well as different options via wizard command to no avail. Tried on both rescue64 and altker64, same result. I believe X.org support for the AST2400 may have been added very recently, so this may just be a matter of needing to update the included software, though I'm not entirely sure. Here is the full console output when attempting to start a session:

Code: Select all

[email protected] /root % startx
xauth:  file /root/.serverauth.2726 does not exist


X.Org X Server 1.15.0
Release Date: 2013-12-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.4.73-fd01 i686 Gentoo
Current Operating System: Linux sysresccd 3.14.9-alt430-amd64 #2 SMP Sat Jun 28 12:10:20 UTC 2014 x86_64
Kernel command line: initrd=sysresccd/430/initram.igz vga=791 setkmap=us cdroot boothttp=http://mirror.webnx.com/pxe/sysresccd/430/sysrcd.dat ip=dhcp BOOT_IMAGE=sysresccd/430/altker64
Build Date: 30 June 2014  01:51:02AM

Current version of pixman: 0.32.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul 28 01:25:49 2014
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension DRI3
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
vesa: Ignoring device with a bound kernel driver
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
[email protected] /root %


Please let me know if I should try anything else or post additional info/logs.

gernot
Posts: 1127
Joined: 07 Apr 2010, 16:19

Re: Xorg support for Aspeed AST2400 VGA controller

Postby gernot » 27 Jul 2014, 18:32

tried you vesa based graphical environment at the bootmenu?

Gernot

Patsiecki
Posts: 2
Joined: 27 Jul 2014, 17:17

Re: Xorg support for Aspeed AST2400 VGA controller

Postby Patsiecki » 27 Jul 2014, 20:06

The vesa-based boot option worked! I can definitely work with this. Further messing with the boot parameters manually it looks like only "nomodeset" is actually necessary to get the system to successfully start an x session, even without "forcevesa" - so food for thought.


Return to “Beta versions (report a bug found in a beta)”

Who is online

Users browsing this forum: No registered users and 2 guests