autoruns from http don't work. Can't resolve domain name.

You can report problems, make suggestions, about the new BETA versions in this forum. For stuff related to final releases, please post a message in other forums
Post Reply
kfa
Posts: 1
Joined: 25 Mar 2011, 12:02

autoruns from http don't work. Can't resolve domain name.

Post by kfa » 25 Mar 2011, 13:03

I am new to systemRescueCD, sorry if this is posted in a wrong plase.

Resolving domain names dossent work because the IP to the domain server is missing.
dns from dhcp server dossent get into /etc/resolv.conf

I am using SystemRescue-Cd 2.1.0-beta006 booting via pxe width this:
label rescuecd
menu label SystemRescueCd
kernel sysrescue/rescuecd
append initrd=sysrescue/initram.igz scandelay=1 setkmap=dk netboot=http://repos.avl/sysrescue/sysrcd.dat ar_source=http://repos.avl/sysrescue autoruns=0

System booting ok, but can't get autorun files from http-server.
cmd: host http-server don't com with an answer.
/etc/resolv.conf:
nameserver 8.8.8.8

If I run dhcpcd (dhcp client demon) it is OK.

I think I fund a bug in /etc/init.d/netconfig2
in line 57:
for curdev in ${NETDEVICES}
${NETDEVICES} shut be ${DHCPDEVICES}

If I run
netconfig2 stop
and
netconfig2 start
the resolv.conf is OK and the resolv is working.

My work around is to put dns=x.x.x.x in the kernel boot line.

/Kim

malte
Posts: 1
Joined: 23 May 2011, 15:29

Re: autoruns from http don't work. Can't resolve domain name

Post by malte » 23 May 2011, 15:33

I was just hit by this, too. It doesn't only apply to http autoruns, but it basically hides our internal host names because it's going to use Google's DNS server instead of our internel one. Passing dns= is not an option for me, as that somehow apparently breaks the search domain right from the beginning.
I came to the same trivial fix:
sed -i -e 's:NETDEVICES:DHCPDEVICES:' /etc/init.d/netconfig2
Is there any chance to get this into the next release?

Thanks,
Malte

eworm
Posts: 27
Joined: 29 Jan 2008, 08:21
Location: Oberhausen
Contact:

Re: autoruns from http don't work. Can't resolve domain name

Post by eworm » 25 May 2011, 10:47

I did not notice that so far... The reason is simple: I redirect the dns traffic to the local service on the gateway... :D
Perhaps this gives anybody a quick workaround.

guoan
Posts: 1
Joined: 15 Jun 2011, 22:18

Re: autoruns from http don't work. Can't resolve domain name

Post by guoan » 15 Jun 2011, 22:23

My work around is to put initscript=dhcpcd:start in the kernel boot line.

- Guoan

Post Reply