NFS boot dont work in 1.6.1beta4

You can report problems, make suggestions, about the new BETA versions in this forum. For stuff related to final releases, please post a message in other forums
Post Reply
gernot
Posts: 1130
Joined: 07 Apr 2010, 16:19

NFS boot dont work in 1.6.1beta4

Post by gernot » 26 Sep 2010, 09:08

It looks like the nfs kernelmodule is missed in the standardkernel initrd.
Booting altker works via NFS

Orginalmessage:
http://www.sysresccd.org/forums/viewtop ... =18&t=3360

Additional this change in /etc/init.d/pxebootsrv would be userfriendly

Code: Select all

                if [ $PXEBOOTSRV_DONBD == "yes" ]
                then
                        sed -i -e "s!scandelay=.!scandelay=5 netboot=nbd://$PXEBOOTSRV_LOCALIP:2000!g" /tftpboot/pxelinux.cfg/default
                fi
+                 if [ $PXEBOOTSRV_DONFSD == "yes" ]
+                 then
+                         sed -i -e "s!scandelay=.!scandelay=5 netboot=nfs://$PXEBOOTSRV_LOCALIP:/tftpboot!g" /tftpboot/pxelinux.cfg/default
+                 fi
        fi
gernot

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: NFS boot dont work in 1.6.1beta4

Post by admin » 27 Sep 2010, 07:14

Thanks for your contribution, these fixes/changes will be in sysresccd-1.6.2-beta001

gernot
Posts: 1130
Joined: 07 Apr 2010, 16:19

Re: NFS boot dont work in 1.6.1beta4

Post by gernot » 30 Sep 2010, 18:27

Thanks, standardkernel NFS-boot is working with new beta

Gernot

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: NFS boot dont work in 1.6.1beta4

Post by admin » 30 Sep 2010, 19:02

Thanks for having confirmed that it works

Post Reply