Mounting not working by default when using nbd

You can report problems, make suggestions, about the new BETA versions in this forum. For stuff related to final releases, please post a message in other forums
Post Reply
Tuipveus
Posts: 103
Joined: 18 Nov 2006, 13:09
Contact:

Mounting not working by default when using nbd

Post by Tuipveus » 08 Sep 2010, 13:36

There is problem when I set one computer to work as nbd-server and another tries to boot from it:

mount: mounting /dev/nbd0 on /squashfs failed: Invalid argument

errorneous command is:

Code: Select all

mount -t squashfs -o ro /dev/nbd0 /squashfs
My suggestion is that this should be modified to form:

Code: Select all

mount -o ro /dev/nbd0 /squashfs
Without specifying fs, mounting works from busybox without problems. Hopefully you dont need to give "-t squashfs" when booting from cdrom etc ?

No idea if this is bug in mount -command, because squashfs is in man-page of the mount, but please leave the fs unspecified if it is possible.

Thanks for keeping is possible to use SRCD with lowend hardware.

gernot
Posts: 1130
Joined: 07 Apr 2010, 16:19

Re: Mounting not working by default when using nbd

Post by gernot » 08 Sep 2010, 14:28

which Version use you?
I never had this problem.

Gernot

Tuipveus
Posts: 103
Joined: 18 Nov 2006, 13:09
Contact:

Re: Mounting not working by default when using nbd

Post by Tuipveus » 09 Sep 2010, 06:49

I am using the latest stable with default kernel and options, but I have added just nbd-bootparameter for the kernel by hand according documentation.

Tuipveus
Posts: 103
Joined: 18 Nov 2006, 13:09
Contact:

Re: Mounting not working by default when using nbd

Post by Tuipveus » 09 Sep 2010, 07:17

I confirm that version 1.6.0 beta 22, does NOT have this bug.
Bug is in 1.5.8 (final)

Tuipveus
Posts: 103
Joined: 18 Nov 2006, 13:09
Contact:

Re: Mounting not working by default when using nbd

Post by Tuipveus » 09 Sep 2010, 13:36

No... I still get error sometimes with 1.6.0 beta 22. I have to restart both server and client to make booting work again. No idea why is that.

Mounting without -t always works.

gernot
Posts: 1130
Joined: 07 Apr 2010, 16:19

Re: Mounting not working by default when using nbd

Post by gernot » 09 Sep 2010, 15:49

when the master need to be rebooted i think its a masterproblem.

Check the interface with ifconfig because Networkmanager can modify the setting while he is stopped.
Check netstat -an for a LISTEN conection at port 2000 or what else you use.
Check also the configfile /tftpboot/pxelinus.cfg/default for the netboot=
line. If there is a line netboot=http:// then you selected
httpboot and ntpboot what makes problems in /etc/conf.d/pxeboot

here are details:
http://www.sysresccd.org/forums/viewtop ... =13&t=3296

gernot

Tuipveus
Posts: 103
Joined: 18 Nov 2006, 13:09
Contact:

Re: Mounting not working by default when using nbd

Post by Tuipveus » 10 Sep 2010, 14:05

Network damager is not causing the problem this time. Port is open and listening, that is not the problem either. It looked like that almost randomly booting works or not work. Most of the time it works.

gernot
Posts: 1130
Joined: 07 Apr 2010, 16:19

Re: Mounting not working by default when using nbd

Post by gernot » 10 Sep 2010, 16:35

so what.
Try to use nbd-client local or from a running PC and compare /dev/nbd... to the shared image.

Gernot

Tuipveus
Posts: 103
Joined: 18 Nov 2006, 13:09
Contact:

Re: Mounting not working by default when using nbd

Post by Tuipveus » 11 Sep 2010, 18:07

local mounting was ok with nbd-client, remote mounting was ok too, if I did not specify type.

According to mount man pages it is ok to say -t squashfs, so I can not understand that what is wrong with the default syntax (in default script of sysresccd). Stupid question, but do we have more than one mount-programs there in different boot stages?

I started booted from nbd about 20-30 times and got this error 2 times with old version and 1 time with newer version.

if mount would not reach the remote computer, it would not complain about syntax of the command, but something else. Why it complains, is mystery for me.

gernot
Posts: 1130
Joined: 07 Apr 2010, 16:19

Re: Mounting not working by default when using nbd

Post by gernot » 11 Sep 2010, 18:37

I think more on a timing thing.

The general mount try one filesystemtype after the other.
This takes much time spezial if dhcp or someting else is not ready.
Manny time to settle ....

The -t squashfs try to mount squashfs and fails.

Try modifying the delay in pxelinux.cfg/default to check this

Gernot

Post Reply